summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c4862fbe256..8acdceff5586 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = acestream-launcher
- pkgdesc = Acestream Launcher allows you to open Acestream links with a Media Player of your choice
- pkgver = 1.3.2
+ pkgdesc = Python interface to interact with the AceStream Engine and the HTTP API
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/jonian/acestream-launcher
arch = any
license = GPL
- makedepends = desktop-file-utils
+ makedepends = python-setuptools
depends = python
+ depends = python-acestream
depends = acestream-engine
optdepends = mpv
optdepends = libnotify
- provides = acestream-launcher
- source = acestream-launcher-1.3.2.tar.gz::https://github.com/jonian/acestream-launcher/archive/v1.3.2.tar.gz
- md5sums = 4a9f9532c072ebdfb27fac020791f40d
+ conflicts = acestream-launcher
+ conflicts = acestream-launcher-git
+ source = acestream-launcher-2.0.0.tar.gz::https://github.com/jonian/acestream-launcher/archive/v2.0.0.tar.gz
+ md5sums = 23884757a9f40cb1a69e66363bac427f
pkgname = acestream-launcher
diff --git a/PKGBUILD b/PKGBUILD
index 08d8fafbc075..a242b39e64f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: Jonian Guveli <https://github.com/jonian/>
pkgname=acestream-launcher
-pkgver=1.3.2
+pkgver=2.0.0
pkgrel=1
-pkgdesc="Acestream Launcher allows you to open Acestream links with a Media Player of your choice"
+pkgdesc="Python interface to interact with the AceStream Engine and the HTTP API"
arch=("any")
url="https://github.com/jonian/acestream-launcher"
license=("GPL")
-depends=("python" "acestream-engine")
+depends=("python" "python-acestream" "acestream-engine")
optdepends=("mpv" "libnotify")
-makedepends=("desktop-file-utils")
-provides=("acestream-launcher")
+makedepends=("python-setuptools")
+conflicts=("${pkgname}" "${pkgname}-git")
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-md5sums=("4a9f9532c072ebdfb27fac020791f40d")
+md5sums=("23884757a9f40cb1a69e66363bac427f")
-package() {
- install -d "$pkgdir/opt"
- install -d "$pkgdir/usr/bin"
- install -d "$pkgdir/usr/share/applications"
-
- cp -a "$srcdir/$pkgname-$pkgver" "$pkgdir/opt/$pkgname"
- ln -s "/opt/$pkgname/acestream_launcher.py" "$pkgdir/usr/bin/acestream-launcher"
- mv -n "$pkgdir/opt/$pkgname/acestream-launcher.desktop" "$pkgdir/usr/share/applications/acestream-launcher.desktop"
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
- update-desktop-database "$pkgdir/opt/$pkgname"
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
}