aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
-rw-r--r--README.md4
4 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05a4c13c5150
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = aci-discovery-git
+ pkgdesc = Serve AppContainer Images and allow their discovery
+ pkgver = r11.b43b592
+ pkgrel = 1
+ url = https://github.com/coreos/aci-discovery
+ arch = any
+ license = Apache
+ makedepends = go
+ source = git+https://github.com/coreos/aci-discovery.git
+ sha256sums = SKIP
+
+pkgname = aci-discovery-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..50c8226efdc2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/aci-discovery
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfc7ac4d852b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Florian Albertz <flo.albertz@gmail.com>
+pkgname="aci-discovery-git"
+pkgver=r11.b43b592
+pkgrel=1
+pkgdesc='Serve AppContainer Images and allow their discovery'
+arch=('any')
+url='https://github.com/coreos/aci-discovery'
+license=('Apache')
+makedepends=('go')
+source=('git+https://github.com/coreos/aci-discovery.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/aci-discovery
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd aci-discovery
+ ./build
+
+ install -d "$pkgdir/opt/aci"
+ install -Dm 755 bin/aci-discovery "$pkgdir/usr/bin/aci-discovery"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..00ed9f0d73d5
--- /dev/null
+++ b/README.md
@@ -0,0 +1,4 @@
+# Aur Package for aci-discovery
+This package simply installs [aci-discovery](https://github.com/coreos/aci-discovery) on an arch System.
+
+The compiled file is installed to `/usr/bin/aci-discovery`.