summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e5ab4d065a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed Mar 1 08:04:18 UTC 2017
+pkgbase = acme.sh-git
+ pkgdesc = An ACME Shell script, an acme client alternative to certbot
+ pkgver = 0.1194.a0037c9
+ pkgrel = 1
+ url = https://github.com/Neilpang/acme.sh
+ arch = any
+ license = GPL3
+ makedepends = git
+ source = acme.sh-git::git+https://github.com/Neilpang/acme.sh.git#branch=master
+ sha256sums = SKIP
+
+pkgname = acme.sh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72f3610ef29d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+
+pkgname=acme.sh-git
+pkgver=0.1194.a0037c9
+pkgrel=1
+pkgdesc="An ACME Shell script, an acme client alternative to certbot"
+arch=('any')
+url="https://github.com/Neilpang/acme.sh"
+license=('GPL3')
+makedepends=('git')
+source=("${pkgname}::git+${url}.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver () {
+ cd "${srcdir}/${pkgname}"
+ echo "0.$(git rev-list --count HEAD).$(git describe --always | sed 's|-|.|g')"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ install -m 755 "${srcdir}/${pkgname}/acme.sh" "${pkgdir}/usr/bin/"
+}