summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--Fix-build-failure-on-gcc-6.patch33
-rw-r--r--PKGBUILD8
3 files changed, 43 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05e32952ce0c..ca17faffbe5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Jan 29 15:39:58 UTC 2017
pkgbase = acoustid-fingerprinter
pkgdesc = Acoustid Fingerprinter is a cross-platform GUI application for submitting audio fingerprints generated by Chromaprint.
pkgver = 0.6
- pkgrel = 7
+ pkgrel = 8
url = http://acoustid.org/fingerprinter
install = acoustid-fingerprinter.install
arch = x86_64
@@ -16,10 +18,12 @@ pkgbase = acoustid-fingerprinter
source = libav10.patch
source = CodecID.patch
source = taglib10.patch
+ source = Fix-build-failure-on-gcc-6.patch
sha256sums = c0165d4210a181b2baa5e72159bf3f1a9b76398da8794305ddf8e1923ca76f32
sha256sums = 0212ac585ac5b923ef1c84d6638bfd76d8339e5af4e69b11fd09084d2d54868e
sha256sums = 8e8f3a136aa0da0e64f154c7724d8092e857177e1cf628e50921df3f615585d2
sha256sums = 1e699c9f590a0e36c45e77af9c78ea302f52fdae9b3d908801cd748ca111ddca
+ sha256sums = 87448ba071890394b4f1c62c49f10ae4ac35e2432d3c94ee989a238353ce110e
pkgname = acoustid-fingerprinter
diff --git a/Fix-build-failure-on-gcc-6.patch b/Fix-build-failure-on-gcc-6.patch
new file mode 100644
index 000000000000..4b915697a896
--- /dev/null
+++ b/Fix-build-failure-on-gcc-6.patch
@@ -0,0 +1,33 @@
+From 632e87969c3a5562a5d4842b03613267ba6236b2 Mon Sep 17 00:00:00 2001
+From: Petter Reinholdtsen <pere@debian.org>
+Date: Sun, 17 Jul 2016 08:59:10 +0200
+Subject: [PATCH] Fix build failure on gcc 6
+
+Array initializers for a char array fail for constants > 128
+on platforms where char is signed. Cast to fix it.
+---
+ gzip.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/gzip.cpp b/gzip.cpp
+index 2aeaad3..35ccf31 100644
+--- a/gzip.cpp
++++ b/gzip.cpp
+@@ -23,12 +23,12 @@ inline unsigned long calculateCrc32(const QByteArray &data)
+ QByteArray gzipCompress(const QByteArray &data)
+ {
+ const char header[10] = {
+- 0x1f, 0x8b, // ID1 + ID2
++ 0x1f, static_cast<char>(0x8b), // ID1 + ID2
+ 8, // Compression Method
+ 0, // Flags
+ 0, 0, 0, 0, // Modification Time
+ 2, // Extra Flags
+- 255, // Operating System
++ static_cast<char>(255), // Operating System
+ };
+
+ QByteArray compressedData = qCompress(data);
+--
+2.11.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 251303238400..0e39e49701b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Wieland Hoffmann <the_mineo@web.de>
pkgname=acoustid-fingerprinter
pkgver=0.6
-pkgrel=7
+pkgrel=8
pkgdesc="Acoustid Fingerprinter is a cross-platform GUI application for submitting audio fingerprints generated by Chromaprint."
arch=('x86_64' 'i686')
url="http://acoustid.org/fingerprinter"
@@ -10,17 +10,19 @@ license=('GPL2')
depends=('ffmpeg' 'qt4' 'chromaprint' 'taglib>=1.6')
makedepends=('cmake')
install=${pkgname}.install
-source=("https://bitbucket.org/acoustid/$pkgname/downloads/$pkgname-$pkgver.tar.gz" libav10.patch CodecID.patch taglib10.patch)
+source=("https://bitbucket.org/acoustid/$pkgname/downloads/$pkgname-$pkgver.tar.gz" libav10.patch CodecID.patch taglib10.patch Fix-build-failure-on-gcc-6.patch)
sha256sums=('c0165d4210a181b2baa5e72159bf3f1a9b76398da8794305ddf8e1923ca76f32'
'0212ac585ac5b923ef1c84d6638bfd76d8339e5af4e69b11fd09084d2d54868e'
'8e8f3a136aa0da0e64f154c7724d8092e857177e1cf628e50921df3f615585d2'
- '1e699c9f590a0e36c45e77af9c78ea302f52fdae9b3d908801cd748ca111ddca')
+ '1e699c9f590a0e36c45e77af9c78ea302f52fdae9b3d908801cd748ca111ddca'
+ '87448ba071890394b4f1c62c49f10ae4ac35e2432d3c94ee989a238353ce110e')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 < ../libav10.patch
patch -p1 < ../CodecID.patch
patch -p1 < ../taglib10.patch
+ patch -p1 < ../Fix-build-failure-on-gcc-6.patch
}
build() {