summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--actiona.patch141
3 files changed, 6 insertions, 158 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52198573a891..791680929a6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = actiona
pkgdesc = A task automation tool that allows you to create and execute action lists
- pkgver = 3.10.0
+ pkgver = 3.10.1
pkgrel = 3
url = https://wiki.actiona.tools
arch = x86_64
@@ -14,10 +14,8 @@ pkgbase = actiona
depends = qt5-multimedia
depends = libnotify
depends = qt5-speech
- source = https://github.com/Jmgr/actiona/archive/v3.10.0.tar.gz
- source = actiona.patch
- sha256sums = 7f7a6ecef82ec51fc5d92e41a9d39d1de190135b1fb6293318feb1d88ceb8757
- sha256sums = 92b1368978b1feb0620095a21b95737d93839ff4bf5f97ec2f1c2b2a1ab4f5ea
+ source = actiona-3.10.1.tar.gz::https://github.com/Jmgr/actiona/archive/v3.10.1.tar.gz
+ sha256sums = 447065e380f8f37db4c8af01df8e1b9d7189cd256205f758845b71d8de6f37ea
pkgname = actiona
diff --git a/PKGBUILD b/PKGBUILD
index 448cc5fa7bc3..d68545e5ce2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=actiona
-pkgver=3.10.0
+pkgver=3.10.1
pkgrel=3
pkgdesc='A task automation tool that allows you to create and execute action lists'
arch=('x86_64')
@@ -9,17 +9,8 @@ url='https://wiki.actiona.tools'
license=('GPL3')
depends=('qt5-script' 'qt5-xmlpatterns' 'qt5-x11extras' 'qt5-multimedia' 'libnotify' 'qt5-speech')
makedepends=('qt5-tools' 'boost' 'opencv')
-source=("https://github.com/Jmgr/${pkgname}/archive/v${pkgver}.tar.gz"
- "${pkgname}.patch")
-sha256sums=('7f7a6ecef82ec51fc5d92e41a9d39d1de190135b1fb6293318feb1d88ceb8757'
- '92b1368978b1feb0620095a21b95737d93839ff4bf5f97ec2f1c2b2a1ab4f5ea')
-
-prepare() {
- cd "${srcdir}"
-
- patch -p0 -i ../${pkgname}.patch
-}
-
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Jmgr/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('447065e380f8f37db4c8af01df8e1b9d7189cd256205f758845b71d8de6f37ea')
build() {
cd "${pkgname}-${pkgver}"
diff --git a/actiona.patch b/actiona.patch
deleted file mode 100644
index b784f5d66798..000000000000
--- a/actiona.patch
+++ /dev/null
@@ -1,141 +0,0 @@
-diff -rupN actiona-3.10.0/actiona.pro actiona-3.10.0b/actiona.pro
---- actiona-3.10.0/actiona.pro 2018-07-17 14:29:12.000000000 -0400
-+++ actiona-3.10.0b/actiona.pro 2019-12-23 09:13:50.937843430 -0500
-@@ -1,21 +1,6 @@
- TEMPLATE = subdirs
- CONFIG = ordered
-
--unix:!mac {
-- !system(pkg-config --exists 'x11') {
-- error(Please install pkg-config) #Here whe assume that x11 is always present, so this is to check if pkg-config is installed
--}
-- !system(pkg-config --exists 'libnotify') {
-- error(Please install libnotify-dev)
--}
-- !system(pkg-config --exists 'xtst') {
-- error(Please install libxtst-dev)
--}
-- !system(pkg-config --exists 'opencv') {
-- error(Please install libopencv-dev)
--}
--}
--
- win32-g++:error(Mingw is currently not supported, please use the Microsoft compiler suite)
-
- contains(DEFINES, ACT_NO_UPDATER){
-diff -rupN actiona-3.10.0/actiontools/actiontools.pro actiona-3.10.0b/actiontools/actiontools.pro
---- actiona-3.10.0/actiontools/actiontools.pro 2018-07-17 14:29:12.000000000 -0400
-+++ actiona-3.10.0b/actiontools/actiontools.pro 2019-12-23 09:13:50.961176893 -0500
-@@ -6,7 +6,7 @@ unix:QT += x11extras
- TEMPLATE = lib
- CONFIG += dll
- unix:CONFIG += link_pkgconfig
--unix:PKGCONFIG += opencv
-+unix:PKGCONFIG += $$PKGCONFIG_OPENCV
- DEFINES += ACTIONTOOLS_LIBRARY
- TARGET = actiontools
- DESTDIR = ..
-diff -rupN actiona-3.10.0/actiontools/keyboardkeyedit.cpp actiona-3.10.0b/actiontools/keyboardkeyedit.cpp
---- actiona-3.10.0/actiontools/keyboardkeyedit.cpp 2018-07-17 14:29:12.000000000 -0400
-+++ actiona-3.10.0b/actiontools/keyboardkeyedit.cpp 2019-12-23 09:13:50.957843541 -0500
-@@ -19,6 +19,7 @@
- */
-
- #include "keyboardkeyedit.h"
-+#include <QKeyEvent>
-
- namespace ActionTools
- {
-diff -rupN actiona-3.10.0/actiontools/opencvalgorithms.cpp actiona-3.10.0b/actiontools/opencvalgorithms.cpp
---- actiona-3.10.0/actiontools/opencvalgorithms.cpp 2018-07-17 14:29:12.000000000 -0400
-+++ actiona-3.10.0b/actiontools/opencvalgorithms.cpp 2019-12-23 09:13:50.947843486 -0500
-@@ -350,7 +350,7 @@ namespace ActionTools
-
- #if CV_MAJOR_VERSION == 2
- const Mat &matImage = image;
--#elif CV_MAJOR_VERSION == 3
-+#elif CV_MAJOR_VERSION >= 3
- cv::Mat matImage = image.getMat(cv::ACCESS_READ);
- #endif
-
-@@ -394,7 +394,7 @@ namespace ActionTools
- {
- #if CV_MAJOR_VERSION == 2
- const cv::Mat &matImage = image;
--#elif CV_MAJOR_VERSION == 3
-+#elif CV_MAJOR_VERSION >= 3
- cv::Mat matImage = image.getMat(cv::ACCESS_READ);
- #endif
-
-@@ -411,7 +411,7 @@ namespace ActionTools
-
- #if CV_MAJOR_VERSION == 2
- return back;
--#elif CV_MAJOR_VERSION == 3
-+#elif CV_MAJOR_VERSION >= 3
- return back.getUMat(cv::ACCESS_RW);
- #endif
- }
-@@ -421,12 +421,22 @@ namespace ActionTools
- switch(method)
- {
- default:
-+#if CV_MAJOR_VERSION < 4
- case ActionTools::OpenCVAlgorithms::CorrelationCoefficientMethod:
- return CV_TM_CCOEFF_NORMED;
- case ActionTools::OpenCVAlgorithms::CrossCorrelationMethod:
- return CV_TM_CCORR_NORMED;
- case ActionTools::OpenCVAlgorithms::SquaredDifferenceMethod:
- return CV_TM_SQDIFF_NORMED;
-+#else
-+ case ActionTools::OpenCVAlgorithms::CorrelationCoefficientMethod:
-+ return cv::TM_CCOEFF_NORMED;
-+ case ActionTools::OpenCVAlgorithms::CrossCorrelationMethod:
-+ return cv::TM_CCORR_NORMED;
-+ case ActionTools::OpenCVAlgorithms::SquaredDifferenceMethod:
-+ return cv::TM_SQDIFF_NORMED;
-+#endif
-+
- }
- }
- }
-diff -rupN actiona-3.10.0/actiontools/opencvalgorithms_private.h actiona-3.10.0b/actiontools/opencvalgorithms_private.h
---- actiona-3.10.0/actiontools/opencvalgorithms_private.h 2018-07-17 14:29:12.000000000 -0400
-+++ actiona-3.10.0b/actiontools/opencvalgorithms_private.h 2019-12-23 09:13:50.957843541 -0500
-@@ -33,7 +33,7 @@ namespace cv
- }
-
- using Mat = cv::Mat;
--#elif CV_MAJOR_VERSION == 3
-+#elif CV_MAJOR_VERSION >= 3
- namespace cv
- {
- class UMat;
-diff -rupN actiona-3.10.0/common.pri actiona-3.10.0b/common.pri
---- actiona-3.10.0/common.pri 2018-07-17 14:29:12.000000000 -0400
-+++ actiona-3.10.0b/common.pri 2019-12-23 09:13:50.937843430 -0500
-@@ -11,6 +11,24 @@ if(!isEmpty(VERSION_OVERRIDE)) {
- ACTIONA_VERSION = $$VERSION_OVERRIDE
- }
-
-+if(isEmpty(PKGCONFIG_OPENCV)) {
-+ PKGCONFIG_OPENCV = opencv
-+}
-+unix:!mac {
-+ !system(pkg-config --exists 'x11') {
-+ error(Please install pkg-config) #Here whe assume that x11 is always present, so this is to check if pkg-config is installed
-+}
-+ !system(pkg-config --exists 'libnotify') {
-+ error(Please install libnotify development libraries (libnotify-dev on Debian))
-+}
-+ !system(pkg-config --exists 'xtst') {
-+ error(Please install XTest development libraries (libxtst-dev on Debian))
-+}
-+ !system(pkg-config --exists '$$PKGCONFIG_OPENCV') {
-+ error(Please install OpenCV development libraries (libopencv-dev on Debian))
-+}
-+}
-+
- DEFINES *= ACT_VERSION=$$ACTIONA_VERSION
- DEFINES *= ACT_SCRIPT_VERSION=$$SCRIPT_VERSION
- DEFINES *= ACT_BUILD_NAME=\\\"$$BUILD_NAME\\\"