summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--actiona.patch22
3 files changed, 36 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8317592a90d0..e92d0bbe3a93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = actiona
pkgdesc = A task automation tool that allows you to create and execute action lists
pkgver = 3.9.4
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.actiona.tools
arch = x86_64
license = GPL3
@@ -14,7 +14,9 @@ pkgbase = actiona
depends = opencv
depends = libnotify
source = https://github.com/Jmgr/actiona/archive/v3.9.4.tar.gz
+ source = actiona.patch
sha256sums = e2537852548d34fa7407324b40b000ef30d8e5deef310ece7a4f938b6be3f185
+ sha256sums = c95371a42dcc2186f06142bd08bce9d65e5c700b51bff8bbb939d5ef25ead899
pkgname = actiona
diff --git a/PKGBUILD b/PKGBUILD
index 3a4984513417..92c882d1659a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,23 @@
pkgname=actiona
pkgver=3.9.4
-pkgrel=1
+pkgrel=2
pkgdesc="A task automation tool that allows you to create and execute action lists"
arch=('x86_64')
url="https://wiki.actiona.tools"
license=('GPL3')
depends=('qt5-script' 'qt5-xmlpatterns' 'qt5-x11extras' 'qt5-multimedia' 'opencv' 'libnotify')
makedepends=('qt5-tools' 'boost')
-source=("https://github.com/Jmgr/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('e2537852548d34fa7407324b40b000ef30d8e5deef310ece7a4f938b6be3f185')
+source=("https://github.com/Jmgr/${pkgname}/archive/v${pkgver}.tar.gz"
+ "${pkgname}.patch")
+sha256sums=('e2537852548d34fa7407324b40b000ef30d8e5deef310ece7a4f938b6be3f185'
+ 'c95371a42dcc2186f06142bd08bce9d65e5c700b51bff8bbb939d5ef25ead899')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ patch -p1 -i ../${pkgname}.patch
+}
build() {
cd "${pkgname}-${pkgver}"
diff --git a/actiona.patch b/actiona.patch
new file mode 100644
index 000000000000..0f73c43386cc
--- /dev/null
+++ b/actiona.patch
@@ -0,0 +1,22 @@
+diff -rupN actiona-3.9.4/actiontools/abstractcodeeditor.h actiona-3.9.4b/actiontools/abstractcodeeditor.h
+--- actiona-3.9.4/actiontools/abstractcodeeditor.h 2018-05-11 16:15:34.000000000 -0400
++++ actiona-3.9.4b/actiontools/abstractcodeeditor.h 2018-05-26 19:13:32.406265232 -0400
+@@ -24,6 +24,7 @@
+ #include "actiontools_global.h"
+
+ #include <QPainter>
++#include <QSet>
+
+ class QAbstractItemModel;
+
+diff -rupN actiona-3.9.4/actiontools/coloredit.cpp actiona-3.9.4b/actiontools/coloredit.cpp
+--- actiona-3.9.4/actiontools/coloredit.cpp 2018-05-11 16:15:34.000000000 -0400
++++ actiona-3.9.4b/actiontools/coloredit.cpp 2018-05-26 19:14:17.386363642 -0400
+@@ -23,6 +23,7 @@
+
+ #include <QColorDialog>
+ #include <QDesktopWidget>
++#include <QRegExpValidator>
+
+ #if (QT_VERSION >= QT_VERSION_CHECK(5, 0, 0))
+ #include <QApplication>