summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD58
-rw-r--r--colors.sh19
4 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c16d74b135a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = adapta-gtk-theme-wal
+ pkgdesc = An adaptive Gtk+ theme based on Material Design Guidelines
+ pkgver = 3.93.0.1
+ pkgrel = 1
+ url = https://github.com/adapta-project/adapta-gtk-theme
+ arch = any
+ license = CCPL
+ license = GPL2
+ makedepends = git
+ makedepends = gnome-shell
+ makedepends = inkscape
+ makedepends = libxml2
+ makedepends = parallel
+ makedepends = sassc
+ optdepends = gtk-engine-murrine: for gtk2 themes
+ optdepends = noto-fonts: Recommended font
+ optdepends = ttf-roboto: Recommended font
+ provides = adapta-gtk-theme
+ conflicts = adapta-gtk-theme
+ source = git+https://github.com/adapta-project/adapta-gtk-theme.git#tag=3.93.0.1
+ source = colors.sh
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = adapta-gtk-theme-wal
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3261d5294dea
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.*
+*.log
+adapta-gtk-theme
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0815880d2f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# $Id$
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Phillip Schichtel <phillip@schich.tel>
+
+pkgname=adapta-gtk-theme-wal
+pkgver=3.93.0.1
+pkgrel=1
+pkgdesc='An adaptive Gtk+ theme based on Material Design Guidelines'
+arch=('any')
+url='https://github.com/adapta-project/adapta-gtk-theme'
+license=('CCPL' 'GPL2')
+makedepends=('git' 'gnome-shell' 'inkscape' 'libxml2' 'parallel' 'sassc')
+optdepends=('gtk-engine-murrine: for gtk2 themes'
+ 'noto-fonts: Recommended font'
+ 'ttf-roboto: Recommended font')
+source=(
+ "git+https://github.com/adapta-project/adapta-gtk-theme.git#tag=${pkgver}"
+ "colors.sh"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
+
+provides=('adapta-gtk-theme')
+conflicts=('adapta-gtk-theme')
+
+build() {
+ cd adapta-gtk-theme
+
+ source "../colors.sh"
+
+ ./autogen.sh \
+ --prefix='/usr' \
+ --enable-parallel \
+ --enable-plank \
+ --enable-telegram \
+ --disable-unity \
+ --enable-gtk_next \
+ --with-selection_color="$color4" \
+ --with-accent_color="$color6" \
+ --with-suggestion_color="$color5" \
+ --with-destruction_color="$color2"
+ make
+}
+
+package() {
+ cd adapta-gtk-theme
+
+ make DESTDIR="${pkgdir}" install
+
+ install -dm 755 "${pkgdir}"/usr/share/plank/themes
+ ln -s /usr/share/themes/Adapta/plank "${pkgdir}"/usr/share/plank/themes/Adapta
+
+ install -Dm 644 LICENSE_CC_BY_SA4 -t "${pkgdir}"/usr/share/licenses/adapta-gtk-theme/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/colors.sh b/colors.sh
new file mode 100644
index 000000000000..69505ecc2625
--- /dev/null
+++ b/colors.sh
@@ -0,0 +1,19 @@
+# Colors
+
+if [[ -z "$WAL" ]]
+then
+ WAL="$HOME/.cache/wal/colors.sh"
+fi
+
+if [[ -f "$WAL" ]]
+then
+ source "$WAL" && return
+fi
+
+# Defaults for if we couldn't source wal's colors.sh
+# If you're building in a chroot or container you can
+# just replace this file with your own.
+color2='#00BCD4'
+color4='#00BCD4'
+color5='#009688'
+color6='#4DB6AC'