summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
-rw-r--r--adb-arm64.install10
3 files changed, 14 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52d7c277397e..8e88fa656b15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,11 +3,12 @@ pkgbase = adb-arm64
pkgver = 5.1.1
pkgrel = 2
url = http://developer.android.com/sdk/index.html
+ install = adb-arm64.install
arch = aarch64
license = custom
depends = zlib
depends = ncurses
- depends = repo
+ depends = android-udev
provides = adb
conflicts = adb
source = adb.service
diff --git a/PKGBUILD b/PKGBUILD
index 7a3c29e5428e..f018cebc02fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,10 @@ pkgdesc='adb for Raspberry 3'
arch=('aarch64')
url='http://developer.android.com/sdk/index.html'
license=('custom')
-depends=('zlib' 'ncurses' 'repo')
+depends=('zlib' 'ncurses' 'android-udev')
provides=('adb')
conflicts=('adb')
+install="adb-arm64.install"
source=("adb.service"
"license.html"
"Makefile")
diff --git a/adb-arm64.install b/adb-arm64.install
new file mode 100644
index 000000000000..365dcd81e420
--- /dev/null
+++ b/adb-arm64.install
@@ -0,0 +1,10 @@
+pre_install() {
+ echo "############################################################################"
+ echo "## You should add current user to 'adbusers' group to be able to use adb. ##"
+ echo "## You will also probably need to reboot as udev rules changed. ##"
+ echo "############################################################################"
+}
+
+pre_upgrade() {
+ pre_install
+}