summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rwxr-xr-xcheck-for-update.sh17
3 files changed, 20 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 766f99611fa5..5835fec73e60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = addinclude
pkgdesc = Add include statements to header and sourcefiles, for C and C++
- pkgver = 1.0.1
- pkgrel = 4
+ pkgver = 1.1.1
+ pkgrel = 1
url = https://addinclude.roboticoverlords.org/
- arch = i686
arch = x86_64
- arch = armv6h
- arch = armv7h
- arch = aarch64
license = GPL2
makedepends = go
- source = https://addinclude.roboticoverlords.org/addinclude-1.0.1.tar.xz
- source = https://addinclude.roboticoverlords.org/addinclude-1.0.1.tar.xz.asc
+ source = https://addinclude.roboticoverlords.org/addinclude-1.1.1.tar.xz
+ source = https://addinclude.roboticoverlords.org/addinclude-1.1.1.tar.xz.asc
validpgpkeys = 962855F072C7A01846405864FCF3C8CB5CF9C8D4
- sha512sums = bb73427f85abd747104e2b24c19da3e1daf31ee0af2f1da5c268ef47cd8657c2e06d6a0611c153afeae1492752926f3765521643ee41a6337a7fe40ca55336aa
- sha512sums = SKIP
+ b2sums = 46a174a39a2e0ba03345707af94443525c8766fd760c48be149bb86314591c949c09b000f5b5dd51fdc410dbd884c5e2e33fac84d9733be38aba2a63e0b2d27e
+ b2sums = SKIP
pkgname = addinclude
-
diff --git a/PKGBUILD b/PKGBUILD
index aaa7204dcb93..6788c6121aad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
-# Maintainer: Kenneth Endfinger <kaendfinger@gmail.com>
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Kenneth Endfinger <kaendfinger@gmail.com>
pkgname=addinclude
-pkgver=1.0.1
-pkgrel=4
+pkgver=1.1.1
+pkgrel=1
pkgdesc='Add include statements to header and sourcefiles, for C and C++'
-arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+arch=(x86_64)
url='https://addinclude.roboticoverlords.org/'
-license=('GPL2')
-makedepends=('go')
+license=(GPL2)
+makedepends=(go)
source=("https://addinclude.roboticoverlords.org/$pkgname-$pkgver.tar.xz"{,.asc})
validpgpkeys=('962855F072C7A01846405864FCF3C8CB5CF9C8D4')
-sha512sums=('bb73427f85abd747104e2b24c19da3e1daf31ee0af2f1da5c268ef47cd8657c2e06d6a0611c153afeae1492752926f3765521643ee41a6337a7fe40ca55336aa'
- 'SKIP')
+b2sums=('46a174a39a2e0ba03345707af94443525c8766fd760c48be149bb86314591c949c09b000f5b5dd51fdc410dbd884c5e2e33fac84d9733be38aba2a63e0b2d27e'
+ 'SKIP')
build() {
- cd "${pkgname}-${pkgver}"
-
- go build -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"
+ cd $pkgname-$pkgver
+ go build -v -mod=vendor -trimpath -buildmode=pie -ldflags="-s -w -extldflags \"${LDFLAGS}\""
}
package() {
- cd "${pkgname}-${pkgver}"
-
- install -Dm755 "${pkgname}-${pkgver}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${pkgname}.1" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
}
-
-# vim: ts=2 sw=2 et:
diff --git a/check-for-update.sh b/check-for-update.sh
deleted file mode 100755
index a7823c96886d..000000000000
--- a/check-for-update.sh
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/usr/bin/env bash
-set -e
-
-cd $(dirname "${0}")
-
-REPOSITORY="xyproto/addinclude"
-
-PKG=$(cat .SRCINFO | grep "pkgbase" | head -n1 | awk '{print $3}')
-CURRENT=$(cat .SRCINFO | grep "pkgver" | head -n1 | awk '{print $3}')
-LATEST=$(curl -n --silent -L "https://api.github.com/repos/${REPOSITORY}/tags" | jq -r '.[].name' | grep -v -- "-" | sed 's/v//g' | sort --version-sort | tail -n1)
-if [ "${LATEST}" != "${CURRENT}" ]
-then
- echo "${PKG} : AUR ${CURRENT} != GitHub ${LATEST}"
- exit 1
-fi
-echo "${PKG} : AUR ${CURRENT} == GitHub ${LATEST}"
-exit 0