summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..550eaf8e4249
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = adlmidi-git
+ pkgdesc = A commandline program that plays MIDI via software OPL3 emulation
+ pkgver = 1.2.6
+ pkgrel = 1
+ url = http://bisqwit.iki.fi/source/adlmidi.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ optdepends = ffmpeg: recording output to video file
+ provides = adlmidi
+ source = git://bisqwit.iki.fi/adlmidi.git
+ sha256sums = SKIP
+
+pkgname = adlmidi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d958ee13212
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Stephen Gregoratto <s.gregoratto@gmail.com>
+
+pkgname="adlmidi-git"
+pkgdesc="OPL3 MIDI player for Linux and Windows"
+pkgrel=1
+pkgver=1.2.6
+pkgdesc="A commandline program that plays MIDI via software OPL3 emulation"
+arch=('i686' 'x86_64')
+url="http://bisqwit.iki.fi/source/adlmidi.html"
+license=('GPL3')
+makedepends=('git')
+optdepends=('ffmpeg: recording output to video file')
+provides=(adlmidi)
+source=("git://bisqwit.iki.fi/adlmidi.git")
+sha256sums=('SKIP')
+
+#pkgver() {
+# cd "${pkgname/-git}"
+# printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+#}
+
+build() {
+ cd "${pkgname/-git}"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ cd "${pkgname/-git}"
+ cp ./adlmidi "$pkgdir/usr/bin/"
+}