summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57592d039099..38eae332de9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = adlmidi-git
license = GPL2+
makedepends = git
optdepends = ffmpeg: recording output to video file
- provides = adlmidi
+ conflicts = adlmidi
source = git://bisqwit.iki.fi/adlmidi.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 563034e494c4..b8c76c74ffe3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stephen Gregoratto <themanhimself@sgregoratto.me>
-pkgname="adlmidi-git"
+pkgname=adlmidi-git
pkgdesc="Commandline program that plays MIDI via software OPL3 emulation"
pkgrel=1
pkgver=1.2.6
@@ -9,13 +9,13 @@ url="https://bisqwit.iki.fi/source/adlmidi.html"
license=('GPL3' 'GPL2+')
makedepends=('git')
optdepends=('ffmpeg: recording output to video file')
-provides=(adlmidi)
+conflicts=(adlmidi)
source=("git://bisqwit.iki.fi/adlmidi.git")
sha256sums=('SKIP')
pkgver() {
cd "${pkgname/-git}"
- printf "%s" "$(git describe origin/release)"
+ git describe --long --tags origin/release | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
}
build() {