summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--adminer.install18
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c433cd6420aa..fae55afab201 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 11 11:05:32 UTC 2016
+# Fri Mar 11 12:02:58 UTC 2016
pkgbase = adminer
pkgdesc = A full-featured MySQL management tool written in PHP.
pkgver = 4.2.4
- pkgrel = 3
+ pkgrel = 4
url = https://www.adminer.org
install = adminer.install
arch = any
@@ -17,7 +17,7 @@ pkgbase = adminer
source = adminer.install
source = httpd-adminer.conf
source = https://www.adminer.org/static/download/4.2.4/adminer-4.2.4.php
- sha256sums = f3d2c8d2119cccf4d84d32ad2662300eecda62ffba7304505e563e192b5a10ef
+ sha256sums = a9b786e220c0deabcb96849ffa511f1ef0b130836f978a8504e1ffbc9c723e51
sha256sums = 176b392620e8d972188685e0e202cba853a2ff5e3d0c90fef130ef1c8c2491c2
sha256sums = ea21b95da1a2f66d26849160f3257823254663144e6b3b506c35160b70c7b3bd
diff --git a/PKGBUILD b/PKGBUILD
index 71838ec0c985..1e5d00849cee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=adminer
pkgver=4.2.4
-pkgrel=3
+pkgrel=4
pkgdesc="A full-featured MySQL management tool written in PHP."
arch=('any')
license=('Apache', 'GPL')
@@ -14,7 +14,7 @@ install=${pkgname}.install
source=("${pkgname}.install"
"httpd-${pkgname}.conf"
"https://www.adminer.org/static/download/${pkgver}/${pkgname}-${pkgver}.php")
-sha256sums=('f3d2c8d2119cccf4d84d32ad2662300eecda62ffba7304505e563e192b5a10ef'
+sha256sums=('a9b786e220c0deabcb96849ffa511f1ef0b130836f978a8504e1ffbc9c723e51'
'176b392620e8d972188685e0e202cba853a2ff5e3d0c90fef130ef1c8c2491c2'
'ea21b95da1a2f66d26849160f3257823254663144e6b3b506c35160b70c7b3bd')
diff --git a/adminer.install b/adminer.install
index 4e4ac3de7b2f..893f68f56ff2 100644
--- a/adminer.install
+++ b/adminer.install
@@ -1,17 +1,17 @@
-TEXT='
-If you want to access adminer interface by your apache server, run following command as root:\n
-echo "Include conf/extra/httpd-adminer.conf" >> /etc/httpd/conf/httpd.conf\n\n
+read -r -d '' MESSAGE << EOM
+If you use apache and want to enable the adminer interface just run the
+following command as root:
-And restart your apache running "rc.d restart httpd"\n
-Or (if you are using systemd) "systemctl restart httpd"\n\n
-
-After you can browse adminer on http://localhost/adminer\n';
+echo "Include conf/extra/httpd-adminer.conf" >> /etc/httpd/conf/httpd.conf
+Restart apache (systemctl restart httpd) and then you can access adminer on
+http://localhost/adminer.
+EOM
post_install() {
- echo -e $TEXT;
+ echo -e "$MESSAGE";
}
post_upgrade() {
- echo -e $TEXT;
+ echo -e "$MESSAGE";
}