summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
-rw-r--r--adminer.install17
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..409ca592e314
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = adminer
+ pkgdesc = A full-featured MySQL management tool written in PHP
+ pkgver = 4.2.1
+ pkgrel = 1
+ url = http://www.adminer.org
+ install = adminer.install
+ arch = any
+ license = Apache License, Version 2.0
+ depends = php
+ optdepends = mysql
+ optdepends = apache
+ optdepends = adminer-skins
+ optdepends = postgresql
+ optdepends = sqlite3
+ conflicts = adminer-git
+ source = http://downloads.sourceforge.net/adminer/adminer-4.2.1.php
+ md5sums = 7b65ca8647349ca14d96735b414e439f
+
+pkgname = adminer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed4405596b26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Sabart Otto - Seberm <seberm[at]gmail[dot]com>
+
+pkgname=adminer
+pkgver=4.2.1
+pkgrel=1
+pkgdesc="A full-featured MySQL management tool written in PHP"
+arch=('any')
+license=('Apache License, Version 2.0')
+depends=('php')
+conflicts=('adminer-git')
+optdepends=('mysql' 'apache' 'adminer-skins' 'postgresql' 'sqlite3')
+url="http://www.adminer.org"
+install=adminer.install
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.php")
+
+package() {
+ _instdir=$pkgdir/usr/share/webapps/$pkgname
+ mkdir -p ${_instdir} $pkgdir/etc/webapps/$pkgname $pkgdir/etc/httpd/conf/extra
+
+ install -D -m644 $srcdir/${pkgname}-${pkgver}.php $_instdir/index.php
+
+ # It's similar to phpMyAdmin
+ cat >$pkgdir/etc/webapps/$pkgname/apache.example.conf <<EOF
+ Alias /${pkgname} "/usr/share/webapps/${pkgname}"
+ <Directory "/usr/share/webapps/${pkgname}">
+ AllowOverride All
+ Options FollowSymlinks
+ Require all granted
+ php_admin_value open_basedir "/srv/:/tmp/:/usr/share/webapps/:/etc/webapps:/usr/share/pear/"
+ </Directory>
+EOF
+
+ cp $pkgdir/etc/webapps/$pkgname/apache.example.conf $pkgdir/etc/httpd/conf/extra/httpd-${pkgname}.conf
+# echo "Include conf/extra/httpd-${pkgname}.conf" >> $pkgdir/etc/httpd/conf/httpd.conf
+
+}
+
+md5sums=('7b65ca8647349ca14d96735b414e439f')
diff --git a/adminer.install b/adminer.install
new file mode 100644
index 000000000000..4e4ac3de7b2f
--- /dev/null
+++ b/adminer.install
@@ -0,0 +1,17 @@
+TEXT='
+If you want to access adminer interface by your apache server, run following command as root:\n
+echo "Include conf/extra/httpd-adminer.conf" >> /etc/httpd/conf/httpd.conf\n\n
+
+And restart your apache running "rc.d restart httpd"\n
+Or (if you are using systemd) "systemctl restart httpd"\n\n
+
+After you can browse adminer on http://localhost/adminer\n';
+
+
+post_install() {
+ echo -e $TEXT;
+}
+
+post_upgrade() {
+ echo -e $TEXT;
+}