summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
-rw-r--r--aegir.install10
-rw-r--r--nginx.conf2
4 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22caec27fd84..8f399bf2c0d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aegir
pkgdesc = Configuration for a dedicated Aegir server to host Drupal sites.
pkgver = 7.x_3.6
- pkgrel = 1
+ pkgrel = 2
url = http://aegirproject.org
install = aegir.install
arch = any
@@ -32,7 +32,7 @@ pkgbase = aegir
md5sums = c744355aae0ae7c5dd1ecadbbc312216
md5sums = 5b5658cd73aa4aa4d7492620a894e8ac
md5sums = d43026960060bc677549baa26a24c9ee
- md5sums = 2a640d69beeea0c03d80b75357a040fe
+ md5sums = e1bb28d05fc072f6cf86d18716cf1f97
md5sums = 75535f9870f06c540f513262a9b7b1ab
md5sums = 496b1fa2533d1306318115e2b02984bd
md5sums = 472dae0f2bd35c58815ec9649eea5861
diff --git a/PKGBUILD b/PKGBUILD
index ebea980a70c1..511ec74249f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=aegir
pkgver=7.x_3.6
-pkgrel=1
+pkgrel=2
pkgdesc="Configuration for a dedicated Aegir server to host Drupal sites."
arch=('any')
url='http://aegirproject.org'
@@ -39,7 +39,7 @@ source=("$pkgname.service"
md5sums=('c744355aae0ae7c5dd1ecadbbc312216'
'5b5658cd73aa4aa4d7492620a894e8ac'
'd43026960060bc677549baa26a24c9ee'
- '2a640d69beeea0c03d80b75357a040fe'
+ 'e1bb28d05fc072f6cf86d18716cf1f97'
'75535f9870f06c540f513262a9b7b1ab'
'496b1fa2533d1306318115e2b02984bd'
'472dae0f2bd35c58815ec9649eea5861'
@@ -64,24 +64,24 @@ package() {
msg2 'Creating $pkgname directory structure'
install --directory --owner=http --group=http --mode=6775 "$pkgdir/etc/drush"{,/cache{,/{complete,default,download,usage}}}
- install --directory --owner=http --group=http --mode=6775 "$pkgdir/usr/share/webapps/$pkgname"
- install --directory --owner=http --group=http --mode=0700 "$pkgdir/usr/share/webapps/$pkgname/.ssh"{,/ctrl-sockets}
+ install --directory --owner=http --group=http --mode=6775 "$pkgdir/var/lib/$pkgname"
+ install --directory --owner=http --group=http --mode=0700 "$pkgdir/var/lib/$pkgname/.ssh"{,/ctrl-sockets}
mkdir -p "$pkgdir/srv/http" "$pkgdir/etc/skel"
ln -s /etc/drush "$pkgdir/srv/http/.drush"
ln -s /etc/drush "$pkgdir/etc/skel/.drush"
- ln -s /etc/drush "$pkgdir/usr/share/webapps/$pkgname/.drush"
- ln -s "/usr/share/webapps/$pkgname/.ssh" "$pkgdir/srv/http/.ssh"
+ ln -s /etc/drush "$pkgdir/var/lib/$pkgname/.drush"
+ ln -s "/var/lib/$pkgname/.ssh" "$pkgdir/srv/http/.ssh"
umask 066
- mkdir -p "$pkgdir/usr/share/webapps/$pkgname/"{config{,/{includes,server_{localhost,master{,/nginx}}}},clients}
+ mkdir -p "$pkgdir/var/lib/$pkgname/"{config{,/{includes,server_{localhost,master{,/nginx}}}},clients}
umask 077
- mkdir -p "$pkgdir/usr/share/webapps/$pkgname/"{backups,config/server_master/nginx/{platform,post,pre,subdir,platform,vhost}.d}
+ mkdir -p "$pkgdir/var/lib/$pkgname/"{backups,config/server_master/nginx/{platform,post,pre,subdir,platform,vhost}.d}
umask 027
- mkdir -p "$pkgdir/usr/share/webapps/$pkgname/"clients/admin
+ mkdir -p "$pkgdir/var/lib/$pkgname/"clients/admin
umask 007
- mkdir -p "$pkgdir/usr/share/webapps/$pkgname/"config/self
- ln -s "/usr/share/webapps/$pkgname/config/server_master/nginx.conf" "$pkgdir/usr/share/webapps/$pkgname/config/nginx.conf"
- ln -s "/usr/share/webapps/$pkgname/config/includes/nginx_vhost_common.conf" "$pkgdir/usr/share/webapps/$pkgname/config/includes/nginx_advanced_include.conf"
- ln -s "/usr/share/webapps/$pkgname/config/includes/nginx_vhost_common.conf" "$pkgdir/usr/share/webapps/$pkgname/config/includes/nginx_simple_include.conf"
+ mkdir -p "$pkgdir/var/lib/$pkgname/"config/self
+ ln -s "/var/lib/$pkgname/config/server_master/nginx.conf" "$pkgdir/var/lib/$pkgname/config/nginx.conf"
+ ln -s "/var/lib/$pkgname/config/includes/nginx_vhost_common.conf" "$pkgdir/var/lib/$pkgname/config/includes/nginx_advanced_include.conf"
+ ln -s "/var/lib/$pkgname/config/includes/nginx_vhost_common.conf" "$pkgdir/var/lib/$pkgname/config/includes/nginx_simple_include.conf"
- chown -R http:http "$pkgdir/etc/drush" "$pkgdir/usr/share/webapps/$pkgname" "$pkgdir/var/spool/cron/$pkgname"
+ chown -R http:http "$pkgdir/etc/drush" "$pkgdir/var/lib/$pkgname" "$pkgdir/var/spool/cron/$pkgname"
}
diff --git a/aegir.install b/aegir.install
index 73bfb5053834..5001df18f60e 100644
--- a/aegir.install
+++ b/aegir.install
@@ -1,6 +1,6 @@
post_install() {
post_upgrade
-
+
echo -n ">>> Testing that localhost resolves to an IP address assigned to a network interface... "
[ $(ip addr | sed --quiet --regexp-extended 's/\s+inet6?\s([^\/]*).*/\1/p' | egrep '^(127.0.0.1|::1)$' | wc -l) -eq 0 ] && echo "Failed." || echo "Passed."
@@ -24,7 +24,7 @@ post_install() {
echo " --client_email=aegir@$(hostname) \\"
echo " --aegir_host=$(hostname) aegir.$(hostname)"
echo " 5. Reconfigure Aegir's nginx configuration to use UNIX sockets instead of a network loopback port:"
- echo " # sed -i 's#127.0.0.1:9000#unix:/run/php-fpm/php-fpm.sock#' /usr/share/webapps/aegir/config/includes/nginx_vhost_common.conf"
+ echo " # sed -i 's#127.0.0.1:9000#unix:/run/php-fpm/php-fpm.sock#' /var/lib/aegir/config/includes/nginx_vhost_common.conf"
echo " 6. Start and start on boot the Aegir stack target:"
echo " # systemctl enable --now aegir.target"
echo " 7. Enable the hosting_queued module/hosting feature, unmask the queue daemon service unit, and restart the Aegir stack:"
@@ -46,14 +46,14 @@ post_upgrade() {
[ $(getent passwd aegir &>/dev/null; echo $?) -eq 0 ] && {
echo "User already exists; no action taken."
} || {
- useradd --gid $(id --group http) --home-dir /usr/share/webapps/aegir --non-unique --uid $(id --user http) aegir
+ useradd --gid $(id --group http) --home-dir /var/lib/aegir --non-unique --uid $(id --user http) aegir
# Replace /etc/passwd with itself having the Aegir user rearranged above the HTTP user.
tempfile=$(mktemp)
cat <(sed -n '1,/^http/p' /etc/passwd | head -n-1) <(getent passwd aegir) <(sed -n '/^http/,$p' /etc/passwd | head -n-1) >| $tempfile
install -m644 $tempfile /etc/passwd
echo "Done."
}
-
+
echo '>>> Setting up shared system-wide drush configuration'
echo ' by symlinking ~/.drush to /etc/drush for all users.'
for user in $(cut --fields=1,6 --delimiter=: /etc/passwd | grep :/home); do
@@ -76,5 +76,5 @@ pre_remove() {
[ $(systemctl --system is-enabled aegir.target) = enabled ] && systemctl --system disable --now aegir.target
[ $(systemctl --system is-active aegir.target) = enabled ] && systemctl --system stop --now aegir.target
[ $(getent passwd aegir &>/dev/null; echo $?) -eq 0 ] && userdel aegir
- echo ">>> There are still files related to Aegir at: /usr/share/webapps/aegir."
+ echo ">>> There are still files related to Aegir at: /var/lib/aegir."
}
diff --git a/nginx.conf b/nginx.conf
index a52732c215e4..61ee694915e4 100644
--- a/nginx.conf
+++ b/nginx.conf
@@ -16,5 +16,5 @@ http {
keepalive_timeout 65;
gzip on;
- include /usr/share/webapps/aegir/config/nginx.conf;
+ include /var/lib/aegir/config/nginx.conf;
}