summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dffc32be8ae..a0d3b90f4b8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Mar 5 13:58:07 UTC 2019
pkgbase = aegisub-git
pkgdesc = A general-purpose subtitle editor with ASS/SSA support
- pkgver = 3.2.2.r344.2cb92a5f7
+ pkgver = 3.2.2.r407.6f546951b
pkgrel = 1
url = http://www.aegisub.org
arch = x86_64
@@ -31,8 +29,10 @@ pkgbase = aegisub-git
conflicts = aegisub
source = aegisub::git+https://github.com/Aegisub/Aegisub.git
source = git+https://github.com/Aegisub/assdraw.git
+ source = 0001-Use-target-name-without-directory-in-_OBJ-macro.patch::https://github.com/Aegisub/Aegisub/commit/6bd3f4c26b8fc1f76a8b797fcee11e7611d59a39.patch
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 12b191b104fc8fa8745fd98f4aa9d2425699f2e2e719ef2062bdf6a025a045c0
pkgname = aegisub-git
diff --git a/PKGBUILD b/PKGBUILD
index fe1e3b156c52..90c30b192518 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
+# Maintainer: Qirui Wang <wqr.prg@gmail.com>
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=aegisub-git
-pkgver=3.2.2.r344.2cb92a5f7
+pkgver=3.2.2.r407.6f546951b
pkgrel=1
pkgdesc='A general-purpose subtitle editor with ASS/SSA support'
arch=(x86_64)
@@ -38,11 +39,11 @@ conflicts=(aegisub)
source=(
aegisub::git+https://github.com/Aegisub/Aegisub.git
git+https://github.com/Aegisub/assdraw.git
+ 0001-Use-target-name-without-directory-in-_OBJ-macro.patch::https://github.com/Aegisub/Aegisub/commit/6bd3f4c26b8fc1f76a8b797fcee11e7611d59a39.patch
)
-sha256sums=(
- SKIP
- SKIP
-)
+sha256sums=('SKIP'
+ 'SKIP'
+ '12b191b104fc8fa8745fd98f4aa9d2425699f2e2e719ef2062bdf6a025a045c0')
pkgver() {
cd aegisub
@@ -56,9 +57,12 @@ prepare() {
cd aegisub
# boost 1.69
- sed 's|gil/gil_all.hpp|gil.hpp|g' -i src/*.cpp
+ #sed 's|gil/gil_all.hpp|gil.hpp|g' -i src/*.cpp
+
+ #sed 's/$(LIBS_BOOST) $(LIBS_ICU)/$(LIBS_BOOST) $(LIBS_ICU) -pthread/' -i tools/Makefile
- sed 's/$(LIBS_BOOST) $(LIBS_ICU)/$(LIBS_BOOST) $(LIBS_ICU) -pthread/' -i tools/Makefile
+ # https://github.com/Aegisub/Aegisub/issues/171
+ patch -p1 -i ../0001-Use-target-name-without-directory-in-_OBJ-macro.patch
cp -f /usr/share/aclocal/ax_boost_{chrono,filesystem,locale,regex,system,thread}.m4 m4macros/
@@ -69,7 +73,7 @@ build() {
cd aegisub
# http://site.icu-project.org/download/61#TOC-Migration-Issues
- CPPFLAGS+=' -DU_USING_ICU_NAMESPACE=1'
+ #CPPFLAGS+=' -DU_USING_ICU_NAMESPACE=1'
./configure \
--prefix=/usr \