summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5369c2101f2..82a621a28b6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo(replacement shim) v8
+# Sun Dec 20 05:16:31 AM EST 2020
pkgbase = aflplusplus
pkgdesc = afl++ is afl with community patches, AFLfast power schedules, qemu 3.1 upgrade + laf-intel support, MOpt mutators, InsTrim instrumentation, unicorn_mode and a lot more!
- pkgver = 2.68c
+ pkgver = 3.00c
pkgrel = 1
url = https://github.com/vanhauser-thc/AFLplusplus
arch = x86_64
@@ -8,8 +10,8 @@ pkgbase = aflplusplus
optdepends = qemu: use QEMU with afl
provides = afl
conflicts = afl
- source = https://github.com/AFLplusplus/AFLplusplus/archive/2.68c.tar.gz
- sha256sums = 862e155c97737770baa26ffedf324a7fa255b757c85b0c9a6f312264f2ca29c5
+ source = https://github.com/AFLplusplus/AFLplusplus/archive/3.0c.tar.gz
+ sha256sums = 75a2cd6c9e14d4160defcf4899c6d654eba9ae1aad2b2c850bb165c84ee763bb
pkgname = aflplusplus
diff --git a/PKGBUILD b/PKGBUILD
index 97e887882fe3..a693287b2f65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer GI Jack <GI_Jack@hackermail.com>
pkgname=aflplusplus
-pkgver=2.68c
+pkgver=3.00c
+_pkgver=3.0c
pkgrel=1
pkgdesc="afl++ is afl with community patches, AFLfast power schedules, qemu 3.1 upgrade + laf-intel support, MOpt mutators, InsTrim instrumentation, unicorn_mode and a lot more!"
arch=('x86_64')
@@ -10,17 +11,21 @@ license=('Apache')
provides=('afl')
conflicts=('afl')
optdepends=('qemu: use QEMU with afl')
-source=("https://github.com/AFLplusplus/AFLplusplus/archive/${pkgver}.tar.gz")
-sha256sums=('862e155c97737770baa26ffedf324a7fa255b757c85b0c9a6f312264f2ca29c5')
+source=("https://github.com/AFLplusplus/AFLplusplus/archive/${_pkgver}.tar.gz")
+sha256sums=('75a2cd6c9e14d4160defcf4899c6d654eba9ae1aad2b2c850bb165c84ee763bb')
+
+prepare() {
+ cd "AFLplusplus-${_pkgver}"
+ make clean
+}
build() {
- cd "AFLplusplus-${pkgver}"
+ cd "AFLplusplus-${_pkgver}"
make PREFIX="/usr"
- make llvm_mode PREFIX="/usr"
}
package() {
- cd "AFLplusplus-${pkgver}"
+ cd "AFLplusplus-${_pkgver}"
make install PREFIX="/usr" DESTDIR="${pkgdir}"
}