summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0b86faf904f..80449c3b658a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo(replacement shim) v8
-# Mon Apr 5 08:23:18 PM EDT 2021
+# Tue Jul 13 10:20:42 AM EDT 2021
pkgbase = aflplusplus
pkgdesc = afl++ is afl with community patches, AFLfast power schedules, qemu 3.1 upgrade + laf-intel support, MOpt mutators, InsTrim instrumentation, unicorn_mode and a lot more!
- pkgver = 3.12c
+ pkgver = 3.13c
pkgrel = 1
url = https://github.com/vanhauser-thc/AFLplusplus
arch = x86_64
@@ -10,8 +10,7 @@ pkgbase = aflplusplus
optdepends = qemu: use QEMU with afl
provides = afl
conflicts = afl
- source = https://github.com/AFLplusplus/AFLplusplus/archive/3.12c.tar.gz
- sha256sums = 0240d34a2f99d157063e31d0c2d2801a68bc015e09187d9cc197637ec8fda635
+ source = https://github.com/AFLplusplus/AFLplusplus/archive/3.13c.tar.gz
+ sha256sums = 7b0d5b17acb38c19878865b91a26ec718fa0ef53363473240c7cfbdbed356f7f
pkgname = aflplusplus
-
diff --git a/PKGBUILD b/PKGBUILD
index d185748c38f3..aa47ef1541e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer GI Jack <GI_Jack@hackermail.com>
pkgname=aflplusplus
-pkgver=3.12c
-_pkgver=3.12c
+pkgver=3.13c
pkgrel=1
pkgdesc="afl++ is afl with community patches, AFLfast power schedules, qemu 3.1 upgrade + laf-intel support, MOpt mutators, InsTrim instrumentation, unicorn_mode and a lot more!"
arch=('x86_64')
@@ -11,21 +10,21 @@ license=('Apache')
provides=('afl')
conflicts=('afl')
optdepends=('qemu: use QEMU with afl')
-source=("https://github.com/AFLplusplus/AFLplusplus/archive/${_pkgver}.tar.gz")
-sha256sums=('0240d34a2f99d157063e31d0c2d2801a68bc015e09187d9cc197637ec8fda635')
+source=("https://github.com/AFLplusplus/AFLplusplus/archive/${pkgver}.tar.gz")
+sha256sums=('7b0d5b17acb38c19878865b91a26ec718fa0ef53363473240c7cfbdbed356f7f')
prepare() {
- cd "AFLplusplus-${_pkgver}"
+ cd "AFLplusplus-${pkgver}"
make clean
}
build() {
- cd "AFLplusplus-${_pkgver}"
+ cd "AFLplusplus-${pkgver}"
make PREFIX="/usr"
}
package() {
- cd "AFLplusplus-${_pkgver}"
+ cd "AFLplusplus-${pkgver}"
make install PREFIX="/usr" DESTDIR="${pkgdir}"
}