summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b44315011f70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = age
+ pkgdesc = A simple, modern and secure file encryption tool
+ pkgver = 1.0.0beta2
+ pkgrel = 1
+ url = https://github.com/FiloSottile/age
+ arch = x86_64
+ license = BSD
+ makedepends = go-pie
+ source = age-1.0.0beta2.tar.gz::https://github.com/FiloSottile/age/archive/v1.0.0-beta2.tar.gz
+ sha256sums = ca0fcfe45415c03c637c2332231f1793bf4dbd6a03e663a71ef2b7554647d763
+
+pkgname = age
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dc905c795c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Tharre <tharre3@gmail.com>
+
+pkgname=age
+_pkgver=1.0.0-beta2
+pkgver=1.0.0beta2
+pkgrel=1
+pkgdesc="A simple, modern and secure file encryption tool"
+arch=('x86_64')
+url="https://github.com/FiloSottile/age"
+license=('BSD')
+makedepends=('go-pie')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/FiloSottile/age/archive/v${_pkgver}.tar.gz")
+sha256sums=('ca0fcfe45415c03c637c2332231f1793bf4dbd6a03e663a71ef2b7554647d763')
+
+build() {
+ cd ${pkgname}-${_pkgver}
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o . ./...
+}
+
+package() {
+ cd ${pkgname}-${_pkgver}
+
+ install -Dm755 age age-keygen -t "${pkgdir}/usr/bin/"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+check() {
+ cd ${pkgname}-${_pkgver}
+ go test ./...
+}