summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98a75562c641
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = agrep-git
+ pkgdesc = Approximate GREP for fast fuzzy string searching.
+ pkgver = r25.27d72ca
+ pkgrel = 1
+ url = https://github.com/Wikinaut/agrep
+ arch = i686
+ arch = x86_64
+ license = ISC
+ makedepends = git
+ makedepends = unzip
+ source = agrep-git::git+https://github.com/Wikinaut/agrep
+ md5sums = SKIP
+
+pkgname = agrep-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03936f63658f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=agrep-git
+pkgver=r25.27d72ca
+pkgrel=1
+epoch=
+pkgdesc="Approximate GREP for fast fuzzy string searching."
+arch=('i686' 'x86_64')
+url="https://github.com/Wikinaut/agrep"
+license=('ISC')
+groups=()
+depends=('')
+makedepends=('git' 'unzip')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/Wikinaut/agrep")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 agrep "$pkgdir/usr/bin/agrep"
+ install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/COPYRIGHT"
+ cd docs/
+ unzip -d $pkgname agrep-and-glimpse-docs.zip
+ install -Dm644 $pkgname/agrep.1 "$pkgdir/usr/share/man/man1/agrep.1"
+}
+