summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD12
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46c901256eb0..69675ba0f082 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = agrum
pkgdesc = C++ Bayesian networks library
- pkgver = 0.15.0
+ pkgver = 1.13.1
pkgrel = 1
url = http://agrum.gitlab.io/
- arch = i686
arch = x86_64
- license = GPL
+ license = LGPL
makedepends = cmake
- depends = python-pydotplus
+ depends = python-pydot
depends = python-matplotlib
+ depends = python-six
depends = ipython
+ depends = python-ipykernel
+ depends = python-pandas
+ depends = python-scikit-learn
+ depends = python-cairosvg
depends = unixodbc
- source = https://gitlab.com/agrumery/aGrUM/-/archive/0.15.0/aGrUM-0.15.0.tar.bz2
- sha256sums = c6b96319e27c6ba1a58973fb75c014cc19786513574a48dc7583a7cb15426f55
+ source = https://gitlab.com/agrumery/aGrUM/-/archive/1.13.1/aGrUM-1.13.1.tar.bz2
+ sha256sums = 80d3b7601fb223ef788346b68e910af43c85a7b08454a9fc5150d5f304ec71c3
pkgname = agrum
-
diff --git a/PKGBUILD b/PKGBUILD
index b13b8298f3b3..18d35acc7443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
pkgname=agrum
-pkgver=0.15.0
+pkgver=1.13.1
pkgrel=1
pkgdesc="C++ Bayesian networks library"
-license=('GPL')
-arch=('i686' 'x86_64')
+license=('LGPL')
+arch=('x86_64')
url="http://agrum.gitlab.io/"
-depends=('python-pydotplus' 'python-matplotlib' 'ipython' 'unixodbc')
+depends=('python-pydot' 'python-matplotlib' 'python-six' 'ipython' 'python-ipykernel' 'python-pandas' 'python-scikit-learn' 'python-cairosvg' 'unixodbc')
makedepends=('cmake')
source=("https://gitlab.com/agrumery/aGrUM/-/archive/${pkgver}/aGrUM-${pkgver}.tar.bz2")
-sha256sums=('c6b96319e27c6ba1a58973fb75c014cc19786513574a48dc7583a7cb15426f55')
+sha256sums=('80d3b7601fb223ef788346b68e910af43c85a7b08454a9fc5150d5f304ec71c3')
build() {
cd "$srcdir/aGrUM-$pkgver"
mkdir -p build && pushd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_PYTHON=ON ..
make
}