summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32c93450dce1..04156c4af6cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Wed Feb 15 19:14:56 UTC 2017
+# Sat Apr 1 20:20:39 UTC 2017
pkgbase = agrum
pkgdesc = C++ Bayesian networks library
- pkgver = 0.10.4
+ pkgver = 0.11.1
pkgrel = 1
- url = https://forge.lip6.fr/projects/aGrUM/wiki
+ url = http://agrum.gitlab.io/
arch = i686
arch = x86_64
license = GPL
@@ -15,8 +15,8 @@ pkgbase = agrum
depends = python-pydotplus
depends = python-matplotlib
depends = ipython
- source = agrum-0.10.4::git+git://forge.lip6.fr/aGrUM#tag=0.10.4
- md5sums = SKIP
+ source = https://gitlab.com/agrumery/aGrUM/repository/archive.tar.bz2?ref=0.11.1
+ sha256sums = f2e9105464dc1fbb2873ba118244888a978232006eb39beb46b5f2e245a6065b
pkgname = agrum
diff --git a/PKGBUILD b/PKGBUILD
index fc8e88fd655a..f080e8606cfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
pkgname=agrum
-pkgver=0.10.4
+pkgver=0.11.1
pkgrel=1
pkgdesc="C++ Bayesian networks library"
license=('GPL')
arch=('i686' 'x86_64')
-url="https://forge.lip6.fr/projects/aGrUM/wiki"
+url="http://agrum.gitlab.io/"
depends=('python-pydotplus' 'python-matplotlib' 'ipython')
makedepends=('cmake' 'cococpp' 'swig' 'python')
-source=("agrum-${pkgver}::git+git://forge.lip6.fr/aGrUM#tag=${pkgver}")
-md5sums=('SKIP')
+source=("https://gitlab.com/agrumery/aGrUM/repository/archive.tar.bz2?ref=${pkgver}")
+sha256sums=('f2e9105464dc1fbb2873ba118244888a978232006eb39beb46b5f2e245a6065b')
prepare() {
+ mv aGrUM-0.11.1-dcfc66b25d4edd3156471ec655c9c6092e6a3327/ $pkgname-$pkgver
cd "$srcdir/$pkgname-$pkgver"
}
@@ -18,6 +19,7 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
mkdir -p build && pushd build
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
}
package() {