summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ba5f64ea606..45130be6e4e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
# Generated by mksrcinfo v8
-# Sun Sep 2 17:18:44 UTC 2018
+# Sun Sep 9 19:31:06 UTC 2018
pkgbase = ags
pkgdesc = A development tool that is primarily used to create graphical adventure games
pkgver = 3.4.1.14
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/adventuregamestudio/ags
arch = x86_64
license = Artistic2.0
makedepends = wxgtk
- depends = allegro4
depends = dumb-a4
- depends = libogg
depends = libtheora
depends = libvorbis
optdepends = wine: for installing and configuring the game
- source = https://github.com/adventuregamestudio/ags/archive/v.3.4.1.14.tar.gz
+ source = ags-3.4.1.14.tar.gz::https://github.com/adventuregamestudio/ags/archive/v.3.4.1.14.tar.gz
source = https://github.com/adventuregamestudio/ags/commit/44d954493bb5f3e95a11a4eddbb62bd6110b1b63.patch
sha256sums = 4ca76b919689c68a9fda4bd56bfb63268ab5326a539ce4d681ac4ed6a908b51c
sha256sums = 6b7092e5794ae532f79c5c6ad5f5761c217b3ec874da43537152fb8e60b20019
diff --git a/PKGBUILD b/PKGBUILD
index 229e43547890..b7397b256259 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,39 +5,39 @@
pkgname=ags
pkgver=3.4.1.14
-pkgrel=2
+pkgrel=3
pkgdesc='A development tool that is primarily used to create graphical adventure games'
arch=('x86_64')
url='https://github.com/adventuregamestudio/ags'
license=('Artistic2.0')
-depends=('allegro4' 'dumb-a4' 'libogg' 'libtheora' 'libvorbis')
+depends=('dumb-a4' 'libtheora' 'libvorbis')
makedepends=('wxgtk')
optdepends=('wine: for installing and configuring the game')
-source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/adventuregamestudio/ags/archive/v.$pkgver.tar.gz"
'https://github.com/adventuregamestudio/ags/commit/44d954493bb5f3e95a11a4eddbb62bd6110b1b63.patch')
sha256sums=('4ca76b919689c68a9fda4bd56bfb63268ab5326a539ce4d681ac4ed6a908b51c'
'6b7092e5794ae532f79c5c6ad5f5761c217b3ec874da43537152fb8e60b20019')
prepare() {
- mv "ags-v.$pkgver" "$pkgname-$pkgver"
+ mv "ags-v.$pkgver" "$pkgname-$pkgver"
- # Copious use of auto_ptr spams the compilation output. Until they're
- # replaced, just suppress the message.
- sed -i 's/-Wfatal-errors/-Wfatal-errors\ -Wno-deprecated-declarations/' \
- "$pkgname-$pkgver/Engine/Makefile-defs.linux"
+ # Copious use of auto_ptr spams the compilation output. Until they're
+ # replaced, just suppress the message.
+ sed -i 's/-Wfatal-errors/-Wfatal-errors\ -Wno-deprecated-declarations/' \
+ "$pkgname-$pkgver/Engine/Makefile-defs.linux"
- # avoid conflicts with glibc functions with the same names
- patch -d "$pkgname-$pkgver" -p1 < ../44d954493bb5f3e95a11a4eddbb62bd6110b1b63.patch
+ # avoid conflicts with glibc functions with the same names
+ patch -d "$pkgname-$pkgver" -p1 < ../44d954493bb5f3e95a11a4eddbb62bd6110b1b63.patch
}
build() {
- cd "ags-v.${pkgver}"
- make -C Engine
+ cd "$pkgname-$pkgver"
+ make -C Engine
}
package() {
- install -Dm755 "ags-v.${pkgver}/Engine/ags" \
- "$pkgdir/usr/bin/ags"
+ install -Dm755 "$pkgname-$pkgver/Engine/ags" \
+ "$pkgdir/usr/bin/ags"
}
# vim: ts=2 sw=2 et