summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
-rw-r--r--ags.install11
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62cfb074ca43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ags
+ pkgdesc = A development tool that is primarily used to create graphical adventure games
+ pkgver = 3.3.4.1
+ pkgrel = 1
+ url = https://github.com/adventuregamestudio/ags
+ install = ags.install
+ arch = i686
+ arch = x86_64
+ license = Artistic2.0
+ makedepends = wxgtk
+ depends = dumb
+ depends = libtheora
+ optdepends = wine: for installing and configuring the game
+ source = https://github.com/adventuregamestudio/ags/archive/v.3.3.4.1.tar.gz
+ sha256sums = ac4ea69bacf3c3f071e97a8489d5cd02921b2868eb9d4c49af138935e8c9b4ea
+
+pkgname = ags
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04497092bcf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ainola
+# Contributor: Ner0
+# Contributor: quantax
+
+pkgname=ags
+pkgver=3.3.4.1
+pkgrel=1
+pkgdesc="A development tool that is primarily used to create graphical adventure games"
+arch=('i686' 'x86_64')
+url="https://github.com/adventuregamestudio/ags"
+license=('Artistic2.0')
+depends=('dumb' 'libtheora')
+makedepends=('wxgtk')
+optdepends=('wine: for installing and configuring the game')
+install=ags.install
+source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz")
+sha256sums=('ac4ea69bacf3c3f071e97a8489d5cd02921b2868eb9d4c49af138935e8c9b4ea')
+
+prepare() {
+ cd "$srcdir/ags-v.${pkgver}"
+ sed -i 's/-Wfatal-errors\ //' Engine/Makefile-defs.linux
+ git submodule update --init
+}
+
+build() {
+ cd "$srcdir/ags-v.${pkgver}"
+ make -C Engine
+}
+
+package() {
+ install -Dm755 "$srcdir/ags-v.${pkgver}/Engine/ags" "$pkgdir/usr/bin/ags"
+ install -Dm644 "$srcdir/ags-v.${pkgver}/License.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ags.install b/ags.install
new file mode 100644
index 000000000000..33f7f11c7a87
--- /dev/null
+++ b/ags.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo ""
+ echo " In order to run a game, you must first install it either with Wine"
+ echo " or just use Windows installation"
+
+ echo " To run it type ags '/GameDir/Game.exe'"
+
+ echo " The native game configurator isn't supported yet,"
+ echo " so you must use the Windows one ('winsetup.exe') with Wine."
+ echo ""
+}