summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD45
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2200f67951e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = aider-chat
+ pkgdesc = AI pair programming in your terminal
+ pkgver = 0.21.0
+ pkgrel = 1
+ url = https://aider.chat/
+ arch = any
+ license = Apache2
+ makedepends = python-packaging
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-configargparse
+ depends = python-gitpython
+ depends = python-openai
+ depends = python-tiktoken
+ depends = python-jsonschema
+ depends = python-rich
+ depends = python-prompt_toolkit
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-backoff
+ depends = python-pathspec
+ depends = python-networkx
+ depends = python-diskcache
+ depends = python-grep-ast
+ depends = python-yaml
+ depends = python-pillow
+ depends = python-diff-match-patch
+ optdepends = python-sounddevice: portaudio support
+ optdepends = python-soundfile: portaudio support
+ provides = aider
+ options = !strip
+ source = https://files.pythonhosted.org/packages/source/a/aider-chat/aider-chat-0.21.0.tar.gz
+ b2sums = 3bbd48f85652f3209fff6204fb02cbcd4c489841c9a22a12fc9eb01d9107f9462de97cc949780abcb265dfa2126be25a4078ac1c235f4d8a32fecdc9e1d68007
+
+pkgname = aider-chat
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06201345eb7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="aider-chat"
+_pkgname="$pkgname"
+pkgver=0.21.0
+pkgrel=1
+pkgdesc="AI pair programming in your terminal"
+url="https://aider.chat/"
+license=("Apache2")
+arch=("any")
+provides=("aider")
+depends=("python-configargparse"
+ "python-gitpython"
+ "python-openai"
+ "python-tiktoken"
+ "python-jsonschema"
+ "python-rich"
+ "python-prompt_toolkit"
+ "python-numpy"
+ "python-scipy"
+ "python-backoff"
+ "python-pathspec"
+ "python-networkx"
+ "python-diskcache"
+ "python-grep-ast"
+ "python-yaml"
+ "python-pillow"
+ "python-diff-match-patch"
+)
+makedepends=("python-packaging" "python-build" "python-installer" "python-wheel")
+optdepends=("python-sounddevice: portaudio support"
+ "python-soundfile: portaudio support")
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+b2sums=('3bbd48f85652f3209fff6204fb02cbcd4c489841c9a22a12fc9eb01d9107f9462de97cc949780abcb265dfa2126be25a4078ac1c235f4d8a32fecdc9e1d68007')
+options=("!strip")
+
+build(){
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package(){
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}