summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rwxr-xr-x[-rw-r--r--]aimp0
-rwxr-xr-x[-rw-r--r--]aimp.desktop0
-rwxr-xr-xaimpac4
-rwxr-xr-xaimpac.desktop14
-rwxr-xr-xaimpate4
-rw-r--r--aimpate.desktop14
8 files changed, 61 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4dc62355a170..d22594f1a7b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,9 +10,17 @@ pkgbase = aimp
depends = hicolor-icon-theme
source = https://www.aimp.ru//files/linux/aimp_5.11-2427_amd64.deb
source = aimp
+ source = aimpac
+ source = aimpate
source = aimp.desktop
+ source = aimpac.desktop
+ source = aimpate.desktop
sha256sums = 295990ef159a65292a7c44522b0401edec85f0cad068f5b0bc367ee25918dbee
sha256sums = b41610f455db4f7600488d49d8df697e85cd554ec3be35d382fa089526f6f051
+ sha256sums = 5ddae7098e215717b7243839686c9c07b6213a9f97fd3c28de5071a48e6942b6
+ sha256sums = 735954b1a61249e2e1ab2ca052330e39ee846e27a89eefb0193cac7ed8f4bebc
sha256sums = bc7f27965c2dd27b483a4a8fb667b125af65343c22764082d7680bd4ce429eaa
+ sha256sums = 638dac1fb0f8271c80789d64eb2a24820d2d2fadadb4fa98f97e8728c2810955
+ sha256sums = 310706f4ee0955956a3b660c86f88ee43e59f06bb1bacd039ab43d017c3a3615
pkgname = aimp
diff --git a/PKGBUILD b/PKGBUILD
index df23870bc4a7..1293a4175f67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,32 @@ arch=('x86_64')
license=('custom')
depends=('wine' 'sh' 'hicolor-icon-theme')
source=("${url}/files/linux/aimp_${pkgver}-${pkgrel}_amd64.deb"
- "${pkgname}"
- "${pkgname}.desktop")
+ "${pkgname}"
+ "${pkgname}ac"
+ "${pkgname}ate"
+ "${pkgname}.desktop"
+ "${pkgname}ac.desktop"
+ "${pkgname}ate.desktop")
sha256sums=('295990ef159a65292a7c44522b0401edec85f0cad068f5b0bc367ee25918dbee'
'b41610f455db4f7600488d49d8df697e85cd554ec3be35d382fa089526f6f051'
- 'bc7f27965c2dd27b483a4a8fb667b125af65343c22764082d7680bd4ce429eaa')
+ '5ddae7098e215717b7243839686c9c07b6213a9f97fd3c28de5071a48e6942b6'
+ '735954b1a61249e2e1ab2ca052330e39ee846e27a89eefb0193cac7ed8f4bebc'
+ 'bc7f27965c2dd27b483a4a8fb667b125af65343c22764082d7680bd4ce429eaa'
+ '638dac1fb0f8271c80789d64eb2a24820d2d2fadadb4fa98f97e8728c2810955'
+ '310706f4ee0955956a3b660c86f88ee43e59f06bb1bacd039ab43d017c3a3615')
package(){
bsdtar -xf "data.tar.gz" -C "${pkgdir}"
install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/${pkgname}ac.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/${pkgname}ate.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${pkgdir}/opt/${pkgname}/AIMP/Assets/logo.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${pkgname}.png"
+ install -Dm644 "${pkgdir}/opt/${pkgname}/AIMP/Assets/ac70x70Logo.png" "${pkgdir}/usr/share/icons/hicolor/72x72/apps/${pkgname}ac.png"
+ install -Dm644 "${pkgdir}/opt/${pkgname}/AIMP/Assets/ate70x70Logo.png" "${pkgdir}/usr/share/icons/hicolor/72x72/apps/${pkgname}ate.png"
install -Dm644 "${pkgdir}/opt/${pkgname}/AIMP/license.rtf" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.rtf"
find "${pkgdir}" -type d -exec chmod 755 {} \;
find "${pkgdir}" -type f -exec chmod 644 {} \;
install -Dm755 "${srcdir}/${pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dm755 "${srcdir}/${pkgname}ac" -t "${pkgdir}/usr/bin"
+ install -Dm755 "${srcdir}/${pkgname}ate" -t "${pkgdir}/usr/bin"
}
diff --git a/aimp b/aimp
index b662973036d7..b662973036d7 100644..100755
--- a/aimp
+++ b/aimp
diff --git a/aimp.desktop b/aimp.desktop
index 8176e6f8bc79..8176e6f8bc79 100644..100755
--- a/aimp.desktop
+++ b/aimp.desktop
diff --git a/aimpac b/aimpac
new file mode 100755
index 000000000000..3941529da939
--- /dev/null
+++ b/aimpac
@@ -0,0 +1,4 @@
+#!/usr/bin/sh
+_args=$(winepath --windows "$@")
+echo "$(basename $0): $_args"
+/usr/bin/wine start /unix '/opt/aimp/AIMP/AIMPac.exe' ${_args}
diff --git a/aimpac.desktop b/aimpac.desktop
new file mode 100755
index 000000000000..5217ca7d424d
--- /dev/null
+++ b/aimpac.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Version=1.0
+Name=Audioconverter AIMP (Wine)
+Name[ru_RU]=Аудиоконвертер AIMP (Wine)
+GenericName=AIMPac
+Icon=aimpac
+Exec=aimpac %F
+Terminal=false
+MimeType=x-content/audio-cdda;audio/x-xm;audio/x-wavpack;audio/x-vorbis+ogg;audio/x-tta;audio/x-stm;audio/x-scpls;audio/x-s3m;audio/x-musepack;audio/x-ms-wma;audio/x-mpegurl;audio/x-mod;audio/x-it;audio/x-ape;audio/mpeg;audio/mpeg;audio/mpeg;audio/mpeg;audio/mp4;audio/mp4;audio/flac;audio/aac;audio/aac;application/x-cue;application/ogg;application/ogg;
+Categories=AudioVideo;Player;Audio;
+Keywords=player;audio;video;multimedia;wine;
+StartupNotify=false
+Type=Application
+X-KDE-SubstituteUID=false
diff --git a/aimpate b/aimpate
new file mode 100755
index 000000000000..96e3a6e29df5
--- /dev/null
+++ b/aimpate
@@ -0,0 +1,4 @@
+#!/usr/bin/sh
+_args=$(winepath --windows "$@")
+echo "$(basename $0): $_args"
+/usr/bin/wine start /unix '/opt/aimp/AIMP/AIMPate.exe' ${_args}
diff --git a/aimpate.desktop b/aimpate.desktop
new file mode 100644
index 000000000000..772763e19ed5
--- /dev/null
+++ b/aimpate.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Version=1.0
+Name=Tag Editor AIMP (Wine)
+Name[ru_RU]=Редактор тегов AIMP (Wine)
+GenericName=AIMPate
+Icon=aimpate
+Exec=aimpate %F
+Terminal=false
+MimeType=x-content/audio-cdda;audio/x-xm;audio/x-wavpack;audio/x-vorbis+ogg;audio/x-tta;audio/x-stm;audio/x-scpls;audio/x-s3m;audio/x-musepack;audio/x-ms-wma;audio/x-mpegurl;audio/x-mod;audio/x-it;audio/x-ape;audio/mpeg;audio/mpeg;audio/mpeg;audio/mpeg;audio/mp4;audio/mp4;audio/flac;audio/aac;audio/aac;application/x-cue;application/ogg;application/ogg;
+Categories=AudioVideo;Player;Audio;
+Keywords=player;audio;video;multimedia;wine;
+StartupNotify=false
+Type=Application
+X-KDE-SubstituteUID=false