summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
-rw-r--r--aimp17
3 files changed, 30 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f282c6f6d928..cec9de305310 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = aimp
pkgdesc = AIMP (on Wine) is powerful free audio player.
pkgver = 5.10
- pkgrel = 2414
+ pkgrel = 2417
url = https://www.aimp.ru/
arch = x86_64
license = custom
depends = wine
- source = https://www.aimp.ru/files/linux/aimp_5.10-2414_amd64.deb
- md5sums = e56fc3e3db95d2baf5160956057cca46
+ source = https://www.aimp.ru/files/linux/aimp_5.10-2417_amd64.deb
+ md5sums = 9b562a6054ce4fec9dd6fdb2f284da46
pkgname = aimp
diff --git a/PKGBUILD b/PKGBUILD
index a8f97c3340be..d60d8c3a932e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,24 @@
pkgname=aimp
pkgver=5.10
-pkgrel=2414
+pkgrel=2417
url="https://www.aimp.ru/"
pkgdesc="AIMP (on Wine) is powerful free audio player."
arch=('x86_64')
license=('custom')
depends=('wine')
source=("https://www.aimp.ru/files/linux/aimp_${pkgver}-${pkgrel}_amd64.deb")
-md5sums=('e56fc3e3db95d2baf5160956057cca46')
+md5sums=('9b562a6054ce4fec9dd6fdb2f284da46')
build(){
cd "${srcdir}"
echo "Append aimp (shell):/usr/bin/aimp"
- #save patch
- echo "#!/usr/bin/sh
-#Convert Linux paths to Windows paths.
-#Example:
-#GNU LINUX | WINDOWS OS
-# \$HOME = %USERPROFILE%\\ (etc).
-_paths=\$(winepath --windows \"\$@\")
-/usr/bin/wine start /unix '/opt/aimp/AIMP/AIMP.exe' \${_paths}" > aimp
}
package(){
desktopfile="aimp.desktop"
+ runner="aimp"
dest="$pkgdir/opt/aimp"
cd "${srcdir}"
@@ -37,12 +30,16 @@ package(){
#set a prompt mode +x
chmod +x "$pkgdir/opt/aimp/${desktopfile}"
+ #remove owner
rm -f "$dest/${desktopfile}"
- rm -f "$dest/aimp.bash"
+ rm -f "$dest/${runner}.bash"
+ #replace owner
#fix owner bug's
+
#append Desktop.file
install -Dm644 ../${desktopfile} "$pkgdir/usr/share/applications/${desktopfile}"
-
- install -Dm755 aimp "$pkgdir/usr/bin/aimp"
+
+ #append /usr/bin/aimp file
+ install -Dm755 ../${runner} "$pkgdir/usr/bin/aimp"
}
diff --git a/aimp b/aimp
new file mode 100644
index 000000000000..56acb60b976c
--- /dev/null
+++ b/aimp
@@ -0,0 +1,17 @@
+#!/usr/bin/sh
+#Convert Linux paths to Windows paths.
+#Example:
+#GNU LINUX | WINDOWS OS
+# $HOME = %USERPROFILE%\ (etc).
+
+#FIX: arguments start with "/" Don't exist to AIMP main command's
+#WHILE: Open Dir, Open Files, set cmd (Stop, Pause, Play, Debug, Next, Prev) worked. And next todo, add-to-playlist, set to playlist .etc. adding.
+
+_args="$1"
+if [ -f $_args ] || [ -d $_args ]; then
+ #arguments is file(s)
+ _args=$(winepath --windows "$@")
+fi
+
+echo $_args
+/usr/bin/wine start /unix '/opt/aimp/AIMP/AIMP.exe' ${_args}