summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD49
-rw-r--r--aimp.desktop42
3 files changed, 43 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 328a13ac8726..4dc62355a170 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,18 @@
pkgbase = aimp
pkgdesc = AIMP (on Wine) is powerful free audio player.
pkgver = 5.11
- pkgrel = 2425
+ pkgrel = 2427
url = https://www.aimp.ru/
arch = x86_64
license = custom
depends = wine
- source = https://www.aimp.ru/files/linux/aimp_5.11-2425_amd64.deb
- md5sums = bb5927d69121f175b093da91bb32d18b
+ depends = sh
+ depends = hicolor-icon-theme
+ source = https://www.aimp.ru//files/linux/aimp_5.11-2427_amd64.deb
+ source = aimp
+ source = aimp.desktop
+ sha256sums = 295990ef159a65292a7c44522b0401edec85f0cad068f5b0bc367ee25918dbee
+ sha256sums = b41610f455db4f7600488d49d8df697e85cd554ec3be35d382fa089526f6f051
+ sha256sums = bc7f27965c2dd27b483a4a8fb667b125af65343c22764082d7680bd4ce429eaa
pkgname = aimp
diff --git a/PKGBUILD b/PKGBUILD
index 74167f64047f..df23870bc4a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,26 @@
-# Maintainer: badcast <lmecomposer@gmail.com>
+# Maintainer: badcast <lmecomposer@gmail.com>
# Contributor: Artem Izmaylov <support@aimp.ru>
-
pkgname=aimp
pkgver=5.11
-pkgrel=2425
+pkgrel=2427
url="https://www.aimp.ru/"
pkgdesc="AIMP (on Wine) is powerful free audio player."
arch=('x86_64')
license=('custom')
-depends=('wine')
-source=("https://www.aimp.ru/files/linux/aimp_${pkgver}-${pkgrel}_amd64.deb")
-md5sums=('bb5927d69121f175b093da91bb32d18b')
-
-build(){
- cd "${srcdir}"
-
- echo "Append aimp (shell):/usr/bin/aimp"
-}
+depends=('wine' 'sh' 'hicolor-icon-theme')
+source=("${url}/files/linux/aimp_${pkgver}-${pkgrel}_amd64.deb"
+ "${pkgname}"
+ "${pkgname}.desktop")
+sha256sums=('295990ef159a65292a7c44522b0401edec85f0cad068f5b0bc367ee25918dbee'
+ 'b41610f455db4f7600488d49d8df697e85cd554ec3be35d382fa089526f6f051'
+ 'bc7f27965c2dd27b483a4a8fb667b125af65343c22764082d7680bd4ce429eaa')
package(){
- desktopfile="aimp.desktop"
- runner="aimp"
- dest="$pkgdir/opt/aimp"
- cd "${srcdir}"
-
- #extract sources
bsdtar -xf "data.tar.gz" -C "${pkgdir}"
-
- #set a prompt mode +x
- chmod +x "$pkgdir/opt/aimp/${desktopfile}"
-
- #remove owner
- rm -f "$dest/${desktopfile}"
- rm -f "$dest/${runner}.bash"
-
- #replace owner
- #fix owner bug's
-
- #append Desktop.file
- install -Dm644 ../${desktopfile} "$pkgdir/usr/share/applications/${desktopfile}"
-
- #append /usr/bin/aimp file
- install -Dm755 ../${runner} "$pkgdir/usr/bin/aimp"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${pkgdir}/opt/${pkgname}/AIMP/Assets/logo.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${pkgname}.png"
+ install -Dm644 "${pkgdir}/opt/${pkgname}/AIMP/license.rtf" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.rtf"
+ find "${pkgdir}" -type d -exec chmod 755 {} \;
+ find "${pkgdir}" -type f -exec chmod 644 {} \;
+ install -Dm755 "${srcdir}/${pkgname}" -t "${pkgdir}/usr/bin"
}
diff --git a/aimp.desktop b/aimp.desktop
index 650225bac243..8176e6f8bc79 100644
--- a/aimp.desktop
+++ b/aimp.desktop
@@ -1,3 +1,22 @@
+[Desktop Entry]
+Version=1.0
+Name=AIMP (Wine)
+Name[ru_RU]=AIMP (Wine)
+GenericName=AIMP
+GenericName[ru_RU]=
+Comment[ru_RU]=Свободный полнофункциональный аудио проигрыватель (Wine)
+Comment=Свободный полнофункциональный аудио проигрыватель (Wine)
+Icon=aimp
+Exec=aimp %F
+Terminal=false
+MimeType=x-content/audio-cdda;audio/x-xm;audio/x-wavpack;audio/x-vorbis+ogg;audio/x-tta;audio/x-stm;audio/x-scpls;audio/x-s3m;audio/x-musepack;audio/x-ms-wma;audio/x-mpegurl;audio/x-mod;audio/x-it;audio/x-ape;audio/mpeg;audio/mpeg;audio/mpeg;audio/mpeg;audio/mp4;audio/mp4;audio/flac;audio/aac;audio/aac;application/x-cue;application/ogg;application/ogg;
+Categories=AudioVideo;Player;Audio;
+Keywords=player;audio;video;multimedia;wine;
+StartupNotify=false
+Type=Application
+X-KDE-SubstituteUID=false
+Actions=Play;Pause;Stop;Previous;Next;
+
[Desktop Action Next]
Exec=aimp /NEXT
Name[ru_RU]=Следующая музыка
@@ -47,26 +66,3 @@ Name[sr@Ijekavian]=Заустави
Name[sr@ijekavianlatin]=Zaustavi
Name[sr@latin]=Zaustavi
Name[sr]=Заустави
-
-[Desktop Entry]
-Actions=Play;Pause;Stop;Previous;Next;
-Categories=AudioVideo;Player;Audio;
-Comment[ru_RU]=Свободный полнофункциональный аудио проигрыватель (Wine)
-Comment=Свободный полнофункциональный аудио проигрыватель (Wine)
-Exec=aimp %F
-GenericName[ru_RU]=
-GenericName=
-Icon=/opt/aimp/AIMP/Assets/logo.png
-Keywords=player;audio;video;multimedia;wine;
-MimeType=x-content/audio-cdda;audio/x-xm;audio/x-wavpack;audio/x-vorbis+ogg;audio/x-tta;audio/x-stm;audio/x-scpls;audio/x-s3m;audio/x-musepack;audio/x-ms-wma;audio/x-mpegurl;audio/x-mod;audio/x-it;audio/x-ape;audio/mpeg;audio/mpeg;audio/mpeg;audio/mpeg;audio/mp4;audio/mp4;audio/flac;audio/aac;audio/aac;application/x-cue;application/ogg;application/ogg;
-Name[ru_RU]=AIMP (Wine)
-Name=AIMP (Wine)
-Path=
-StartupNotify=true
-Terminal=false
-TerminalOptions=
-Type=Application
-X-DBUS-ServiceName=
-X-DBUS-StartupType=
-X-KDE-SubstituteUID=false
-X-KDE-Username=