summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dccac60d3964..a8f97c3340be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,12 @@ build(){
echo "Append aimp (shell):/usr/bin/aimp"
#save patch
echo "#!/usr/bin/sh
-/usr/bin/wine '/opt/aimp/AIMP/AIMP.exe' \"\$@\"" > aimp
+#Convert Linux paths to Windows paths.
+#Example:
+#GNU LINUX | WINDOWS OS
+# \$HOME = %USERPROFILE%\\ (etc).
+_paths=\$(winepath --windows \"\$@\")
+/usr/bin/wine start /unix '/opt/aimp/AIMP/AIMP.exe' \${_paths}" > aimp
}
package(){