summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD8
4 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb1cae834c69..aada71f70f37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = air
pkgdesc = Live reload for Go apps
- pkgver = 1.50.0
+ pkgver = 1.52.0
pkgrel = 1
url = https://github.com/cosmtrek/air
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = git
depends = glibc
depends = go
options = !lto
- source = air::git+https://github.com/cosmtrek/air.git#commit=eb5b1b501bf2a69316cfc75648c2eebba98d0553
- b2sums = SKIP
+ source = air::git+https://github.com/cosmtrek/air.git#commit=df2c1370868b79ab68b5091194a5c0090b34e1aa
+ b2sums = e5b85406e9d3ef63b01276df89ffc4a0aa1301ca6d96440873d53335b3ded897fe7aa504aa708791606aa4ee7f05b7b202e32317cdd711a6c978ccf53e4551bc
pkgname = air
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..6689d2ed153a
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[air]
+source = "github"
+github = "cosmtrek/air"
+use_latest_release = "true"
+prefix = "v"
diff --git a/PKGBUILD b/PKGBUILD
index 609e11b7d94e..2b67603d4197 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: George Rawlinson <george@rawlinson.net.nz>
pkgname=air
-pkgver=1.50.0
+pkgver=1.52.0
pkgrel=1
pkgdesc="Live reload for Go apps"
arch=(x86_64)
url="https://github.com/cosmtrek/${pkgname}"
-license=(GPL3)
+license=(GPL-3.0-or-later)
depends=(glibc go)
makedepends=(git)
options=('!lto')
-_commit='eb5b1b501bf2a69316cfc75648c2eebba98d0553'
+_commit='df2c1370868b79ab68b5091194a5c0090b34e1aa'
source=("${pkgname}::git+${url}.git#commit=${_commit}")
-b2sums=('SKIP')
+b2sums=('e5b85406e9d3ef63b01276df89ffc4a0aa1301ca6d96440873d53335b3ded897fe7aa504aa708791606aa4ee7f05b7b202e32317cdd711a6c978ccf53e4551bc')
pkgver() {
cd ${pkgname}