summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD6
3 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba17d255f464..3ca38e3dc7c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = airwindows-git
pkgdesc = Airwindows plugins are modular, graphic-less, stripped-down, VST plugins for Mac and PC
- pkgver = r130.0d16be1
+ pkgver = r225.a4343495
pkgrel = 1
url = https://www.airwindows.com/
arch = x86_64
@@ -17,4 +17,3 @@ pkgbase = airwindows-git
sha256sums = SKIP
pkgname = airwindows-git
-
diff --git a/.gitignore b/.gitignore
index aabc5d3e2544..5d6275b12559 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,5 @@
*.log
pkg/
src/
+airwindows
+CMakeLists.txt
diff --git a/PKGBUILD b/PKGBUILD
index bc3aa4614334..289d6c220c80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Teteros <teteros at teknik dot io>
pkgname=airwindows-git
-pkgver=r130.0d16be1
+pkgver=r225.a4343495
pkgrel=1
pkgdesc="Airwindows plugins are modular, graphic-less, stripped-down, VST plugins for Mac and PC"
arch=(x86_64)
@@ -24,13 +24,13 @@ prepare() {
# Fix cmake build, see:
# https://github.com/airwindows/airwindows/pull/5
rm -f build/CMakeCache.txt
- mkdir -p include/vstsdk
+ mkdir -p include/vstsdk build
cp "${srcdir}/CMakeLists.txt" include/vstsdk/CMakeLists.txt
}
build() {
cd "${pkgname%-*}/plugins/LinuxVST/build"
- cmake -DVSTSDK_ROOT=/usr/include/vst36 ..
+ cmake -DVSTSDK_ROOT=/usr/include/vst36 -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS="-O3 -ffast-math" ..
make || return 1
}