summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD21
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e7f3605520d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = akmey-bin
+ pkgdesc = Akmey client
+ pkgver = 0.1.7
+ pkgrel = 1
+ url = https://github.com/akmey/akmey-client
+ arch = x86_64
+ license = custom: Unlicense
+ conflicts = akmey
+ noextract = akmey-client-linux-amd64
+ source = https://github.com/akmey/akmey-client/releases/download/v0.1.7-alpha/akmey-client-linux-amd64
+ sha512sums = d2311d149b0d93a83ec7130261e0f732ac32151ee8df2cf8d8f46bea2686b8ba468a8cb488c5a3385b969a5adf6a6db894495cd9231d82df98bd2c7900f4cdf1
+
+pkgname = akmey-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..cf1ab25da034
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd57cc330cac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Luclu7 <me at luclu7 dot fr>
+pkgname=akmey-bin
+pkgver=0.1.7
+pkgrel=1
+pkgdesc="Akmey client"
+arch=('x86_64')
+url="https://github.com/akmey/akmey-client"
+license=('custom: Unlicense')
+conflicts=('akmey')
+source=("https://github.com/akmey/akmey-client/releases/download/v$pkgver-alpha/akmey-client-linux-amd64")
+noextract=('akmey-client-linux-amd64')
+sha512sums=('d2311d149b0d93a83ec7130261e0f732ac32151ee8df2cf8d8f46bea2686b8ba468a8cb488c5a3385b969a5adf6a6db894495cd9231d82df98bd2c7900f4cdf1')
+
+warn_build_references() {
+ : # I like __FILE__ and don't consider build references to be a problem
+}
+
+package() {
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 akmey-client-linux-amd64 "$pkgdir/usr/bin/akmey"
+}