summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD4
-rwxr-xr-xcompile.bash2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79ad5df4f11f..513a441595a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alchemy-next-viewer-git
pkgdesc = A Second Life client with focus on performance and code correctness. - Git Source build
pkgver = 6.10.50645.fc66e8157b
- pkgrel = 1
+ pkgrel = 2
url = https://www.alchemyviewer.org
install = alchemy.install
arch = x86_64
@@ -47,6 +47,6 @@ pkgbase = alchemy-next-viewer-git
source = alchemy-next-viewer-git::git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main
source = compile.bash
sha256sums = SKIP
- sha256sums = 49def0cfca9afb8c20712d74a38b9b95fc9526317be63ae3d08cee1f2835c564
+ sha256sums = 3a259090109826d656a89af2c627856884732008072017f63912a5efe6f69c9b
pkgname = alchemy-next-viewer-git
diff --git a/PKGBUILD b/PKGBUILD
index b0fc03db3e48..5bd13820ad5f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# shellcheck disable=2034,3030,2154
pkgname=alchemy-next-viewer-git
pkgver=6.10.50645.fc66e8157b
-pkgrel=1
+pkgrel=2
pkgdesc="A Second Life client with focus on performance and code correctness. - Git Source build"
arch=('x86_64')
url=https://www.alchemyviewer.org
@@ -31,7 +31,7 @@ install=alchemy.install
source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch='"${AL_BRANCH_OVERRIDE:-main}"
'compile.bash')
sha256sums=('SKIP'
- '49def0cfca9afb8c20712d74a38b9b95fc9526317be63ae3d08cee1f2835c564')
+ '3a259090109826d656a89af2c627856884732008072017f63912a5efe6f69c9b')
pkgver() {
cd "${pkgname}" || exit 1
diff --git a/compile.bash b/compile.bash
index 7b5c44e4f9a0..9f4355a5f529 100755
--- a/compile.bash
+++ b/compile.bash
@@ -65,7 +65,7 @@ build() {
AL_CMAKE_CONFIG=(
-DLL_TESTS:BOOL=OFF
-DDISABLE_FATAL_WARNINGS=ON
- -DUSE_LTO:BOOL=ON
+ -DUSE_LTO:BOOL=OFF
-DVIEWER_CHANNEL="Alchemy Test"
-DCMAKE_C_FLAGS="$AL_ARCH_FLAGS"
-DCMAKE_CXX_FLAGS="$AL_ARCH_FLAGS"