summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD8
-rwxr-xr-xcompile.bash4
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c92193657090..79ad5df4f11f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = alchemy-next-viewer-git
pkgdesc = A Second Life client with focus on performance and code correctness. - Git Source build
- pkgver = 6.9.50471.6252c244f0
- pkgrel = 2
+ pkgver = 6.10.50645.fc66e8157b
+ pkgrel = 1
url = https://www.alchemyviewer.org
install = alchemy.install
arch = x86_64
license = LGPL
makedepends = cmake
- makedepends = clang
+ makedepends = gcc
makedepends = lld
makedepends = python-virtualenv
makedepends = python-pip
@@ -47,6 +47,6 @@ pkgbase = alchemy-next-viewer-git
source = alchemy-next-viewer-git::git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main
source = compile.bash
sha256sums = SKIP
- sha256sums = 3e00fe0baac4ac938d79bcc591b04183c0d8e6fa266ecf69e864ede66d7a0846
+ sha256sums = 49def0cfca9afb8c20712d74a38b9b95fc9526317be63ae3d08cee1f2835c564
pkgname = alchemy-next-viewer-git
diff --git a/PKGBUILD b/PKGBUILD
index 51103e786b27..b0fc03db3e48 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
#
# shellcheck disable=2034,3030,2154
pkgname=alchemy-next-viewer-git
-pkgver=6.9.50471.6252c244f0
-pkgrel=2
+pkgver=6.10.50645.fc66e8157b
+pkgrel=1
pkgdesc="A Second Life client with focus on performance and code correctness. - Git Source build"
arch=('x86_64')
url=https://www.alchemyviewer.org
license=('LGPL')
depends=(dbus-glib glu gtk3 libgl libiconv libidn libjpeg-turbo libpng libxss libxml2 mesa nss openal sdl2 vlc zlib)
-makedepends=('cmake' 'clang' 'lld' 'python-virtualenv' 'python-pip' 'git' 'boost' 'xz' 'ninja')
+makedepends=('cmake' 'gcc' 'lld' 'python-virtualenv' 'python-pip' 'git' 'boost' 'xz' 'ninja')
optdepends=(
'alsa-lib: ALSA support'
'freealut: OpenAL support'
@@ -31,7 +31,7 @@ install=alchemy.install
source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch='"${AL_BRANCH_OVERRIDE:-main}"
'compile.bash')
sha256sums=('SKIP'
- '3e00fe0baac4ac938d79bcc591b04183c0d8e6fa266ecf69e864ede66d7a0846')
+ '49def0cfca9afb8c20712d74a38b9b95fc9526317be63ae3d08cee1f2835c564')
pkgver() {
cd "${pkgname}" || exit 1
diff --git a/compile.bash b/compile.bash
index a68278bb9737..7b5c44e4f9a0 100755
--- a/compile.bash
+++ b/compile.bash
@@ -69,8 +69,8 @@ build() {
-DVIEWER_CHANNEL="Alchemy Test"
-DCMAKE_C_FLAGS="$AL_ARCH_FLAGS"
-DCMAKE_CXX_FLAGS="$AL_ARCH_FLAGS"
- -DCMAKE_C_COMPILER=clang
- -DCMAKE_CXX_COMPILER=clang++
+ -DCMAKE_C_COMPILER="${CC:-gcc}"
+ -DCMAKE_CXX_COMPILER="${CXX:-g++}"
)
# I could not find the documentation on how to handle BUILDENV/OPTION in
# makepkg.conf. If you are reading this and know where it is,