summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD10
-rwxr-xr-xcompile.bash17
3 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3be4d7bf855..35bd70cf7dc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alchemy-viewer-git
pkgdesc = This is the next generation of Alchemy Viewer! - Git Source build
pkgver = 6.5.5_r48681.g12c2a9b7e9
- pkgrel = 5
+ pkgrel = 6
url = https://www.alchemyviewer.org
install = alchemy.install
arch = x86_64
@@ -43,12 +43,12 @@ pkgbase = alchemy-viewer-git
provides = alchemy-viewer
replaces = alchemy-next-viewer-git
options = !emptydirs
- options = !makeflags
+ options = !buildflags
options = !strip
options = !lto
source = alchemy-viewer-git::git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main
source = compile.bash
b2sums = SKIP
- b2sums = 67d8687b690f40a391b3374c1c7bb8d3ff9ea488b9b67742b92079c00ff43e091a80e281fcf81a62dd0b8c4f35aedc385593ac48f6dce0298440285c296058ed
+ b2sums = 09727e5b1f2aa9f288defb81531cbc10f40a58d34d6276ea241495f149b0d180ec24ee5e3cbcb3043d62e8a6dd729681dca909ea06878932a96a34766e07efc8
pkgname = alchemy-viewer-git
diff --git a/PKGBUILD b/PKGBUILD
index ccb8f386b0dc..ee2a0ee9392d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# shellcheck disable=2034,3030,2154
pkgname=alchemy-viewer-git
pkgver=6.5.5_r48681.g12c2a9b7e9
-pkgrel=5
+pkgrel=6
pkgdesc="This is the next generation of Alchemy Viewer! - Git Source build"
arch=('x86_64')
url=https://www.alchemyviewer.org
@@ -31,7 +31,7 @@ install=alchemy.install
source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch='"${AL_BRANCH_OVERRIDE:-main}"
'compile.bash')
b2sums=('SKIP'
- '3e2b3c952ddb353e159f9f65565fb6838428e39bda0fa062019cfde9158d36f6aaff71a52b13e39fe25e8cd98f8a11097f0d59b152c58dedbb951aae3f9c71f6')
+ '09727e5b1f2aa9f288defb81531cbc10f40a58d34d6276ea241495f149b0d180ec24ee5e3cbcb3043d62e8a6dd729681dca909ea06878932a96a34766e07efc8')
pkgver() {
cd "${pkgname}" || exit 1
@@ -48,12 +48,6 @@ prepare() {
build() {
cd "${pkgname}" || exit 1
- # I could not find the documentation on how to handle BUILDENV/OPTION in
- # makepkg.conf. If you are reading this and know where it is,
- # please send it my way.
- if ! command -v ccache > /dev/null 2>&1; then
- export AL_NOCCACHE=1
- fi
../../compile.bash build
}
diff --git a/compile.bash b/compile.bash
index 4e915121d973..c386171b33b9 100755
--- a/compile.bash
+++ b/compile.bash
@@ -48,11 +48,6 @@ build() {
fi
fi
fi
- if pacman -Qq ccache &> /dev/null; then
- export PATH="/usr/lib/ccache/bin/:$PATH"
- export CCACHE_SLOPPINESS="file_macro,locale,time_macros"
- export CCACHE_NOHASHDIR="true"
- fi
export AUTOBUILD_CPU_COUNT=$build_jobs
AL_ARCH_FLAGS=${AL_ARCH_FLAGS:-'-march=x86-64-v2 -mtune=native'}
@@ -64,8 +59,16 @@ build() {
-DCMAKE_C_FLAGS="$AL_ARCH_FLAGS"
-DCMAKE_CXX_FLAGS="$AL_ARCH_FLAGS"
)
- if [[ -z "$AL_NO_CCACHE" ]]; then
- ccache --set-config=sloppiness=file_macro,locale,time_macros
+ # I could not find the documentation on how to handle BUILDENV/OPTION in
+ # makepkg.conf. If you are reading this and know where it is,
+ # please send it my way.
+ if [[ -n "$AL_NO_CCACHE" ]] || ! command -v ccache 2 > /dev/null 2>&1; then
+ echo "ccache disabled"
+ AL_CMAKE_CONFIG+=(-UCMAKE_CXX_COMPILER_LAUNCHER)
+ else
+ echo "ccache available and enabled"
+ export CCACHE_SLOPPINESS="file_macro,locale,time_macros"
+ export CCACHE_NOHASHDIR="true"
AL_CMAKE_CONFIG+=(-DCMAKE_CXX_COMPILER_LAUNCHER=ccache)
fi
$prefix_cmd autobuild configure -A 64 -c ReleaseOS -- "${AL_CMAKE_CONFIG[@]}"