summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--alephone-update-old-ffmpeg-enums.patch99
3 files changed, 112 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 283b872d6951..4e15980e66d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alephone
pkgdesc = A free, enhanced port of the classic FPS "Marathon 2" by Bungie Software
pkgver = 1.2.1_20150620
- pkgrel = 1
+ pkgrel = 2
url = http://marathon.sourceforge.net/
arch = i686
arch = x86_64
@@ -28,10 +28,10 @@ pkgbase = alephone
optdepends = alephone-red: community-made scenario
optdepends = alephone-rubiconx: community-made scenario
optdepends = alephone-tempus_irae: community-made scenario
- source = http://downloads.sourceforge.net/marathon/AlephOne-20150620.tar.bz2
- source = http://downloads.sourceforge.net/marathon/README.md
+ source = https://github.com/Aleph-One-Marathon/alephone/releases/download/release-20150620/AlephOne-20150620.tar.bz2
+ source = alephone-update-old-ffmpeg-enums.patch
sha256sums = c0f360dfb74a6264f95d375103a74000930cf0439ffb0464f915f5379443e133
- sha256sums = 2eb7fedcd6d4f85b3dc62b3c26f08d8f620fe670f504dafb411787e09ff3b9d9
+ sha256sums = 2c83da1a751e677d8a980e27e3df684943f7b6b883aca5b047a11783232d4324
pkgname = alephone
diff --git a/PKGBUILD b/PKGBUILD
index 98abab9b3766..f56cbba178ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=alephone
_pkgdate=20150620
pkgver=1.2.1_$_pkgdate
-pkgrel=1
+pkgrel=2
pkgdesc='A free, enhanced port of the classic FPS "Marathon 2" by Bungie Software'
arch=('i686' 'x86_64')
url="http://marathon.sourceforge.net/"
@@ -25,14 +25,17 @@ optdepends=('alephone-emr: community-made scenario'
'alephone-rubiconx: community-made scenario'
'alephone-tempus_irae: community-made scenario')
makedepends=('boost' 'mesa' 'icoutils')
-source=("http://downloads.sourceforge.net/marathon/AlephOne-$_pkgdate.tar.bz2"
- "http://downloads.sourceforge.net/marathon/README.md")
+source=("https://github.com/Aleph-One-Marathon/alephone/releases/download/release-$_pkgdate/AlephOne-$_pkgdate.tar.bz2"
+ "$pkgname-update-old-ffmpeg-enums.patch")
sha256sums=('c0f360dfb74a6264f95d375103a74000930cf0439ffb0464f915f5379443e133'
- '2eb7fedcd6d4f85b3dc62b3c26f08d8f620fe670f504dafb411787e09ff3b9d9')
+ '2c83da1a751e677d8a980e27e3df684943f7b6b883aca5b047a11783232d4324')
prepare() {
cd AlephOne-$_pkgdate
+ # backported patch to make it compile correctly
+ patch -Np1 < ../$pkgname-update-old-ffmpeg-enums.patch
+
# lowercase for (folder) name
sed "s|PACKAGE='AlephOne'|PACKAGE='alephone'|g" -i configure
@@ -61,6 +64,6 @@ package() {
install -m644 Resources/*.png "$pkgdir"/usr/share/icons
# docs
- install -Dm644 ../README.md "$pkgdir"/usr/share/doc/$pkgname/README-${pkgver%_*}.md
- install -m644 README docs/*.html "$pkgdir"/usr/share/doc/$pkgname
+ install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+ install -m644 docs/*.html "$pkgdir"/usr/share/doc/$pkgname
}
diff --git a/alephone-update-old-ffmpeg-enums.patch b/alephone-update-old-ffmpeg-enums.patch
new file mode 100644
index 000000000000..a0def0a0f00e
--- /dev/null
+++ b/alephone-update-old-ffmpeg-enums.patch
@@ -0,0 +1,99 @@
+From 26c8edfa5511dd954a08335c15f41833e9bfc048 Mon Sep 17 00:00:00 2001
+From: Hopper262 <hopper@whpress.com>
+Date: Wed, 6 Jan 2016 00:59:21 -0500
+Subject: [PATCH] update old ffmpeg enums (should fix #10, #11)
+
+---
+ Source_Files/FFmpeg/Movie.cpp | 4 ++--
+ Source_Files/FFmpeg/SDL_ffmpeg.c | 14 +++++++-------
+ 2 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/Source_Files/FFmpeg/Movie.cpp b/Source_Files/FFmpeg/Movie.cpp
+index 3b59853..a0074a7 100644
+--- a/Source_Files/FFmpeg/Movie.cpp
++++ b/Source_Files/FFmpeg/Movie.cpp
+@@ -420,7 +420,7 @@ bool Movie::Setup()
+ video_stream->codec->width = view_rect.w;
+ video_stream->codec->height = view_rect.h;
+ video_stream->codec->time_base = (AVRational){1, TICKS_PER_SECOND};
+- video_stream->codec->pix_fmt = PIX_FMT_YUV420P;
++ video_stream->codec->pix_fmt = AV_PIX_FMT_YUV420P;
+ video_stream->codec->flags |= CODEC_FLAG_CLOSED_GOP;
+ video_stream->codec->thread_count = get_cpu_count();
+
+@@ -539,7 +539,7 @@ bool Movie::Setup()
+ // initialize conversion context
+ if (success)
+ {
+- av->sws_ctx = sws_getContext(temp_surface->w, temp_surface->h, PIX_FMT_RGB32,
++ av->sws_ctx = sws_getContext(temp_surface->w, temp_surface->h, AV_PIX_FMT_RGB32,
+ video_stream->codec->width,
+ video_stream->codec->height,
+ video_stream->codec->pix_fmt,
+diff --git a/Source_Files/FFmpeg/SDL_ffmpeg.c b/Source_Files/FFmpeg/SDL_ffmpeg.c
+index 609c908..203b049 100644
+--- a/Source_Files/FFmpeg/SDL_ffmpeg.c
++++ b/Source_Files/FFmpeg/SDL_ffmpeg.c
+@@ -86,7 +86,7 @@ extern int convert_audio(int in_samples, int in_channels, int in_stride,
+ * Provide a fast way to get the correct context.
+ * \returns The context matching the input values.
+ */
+-struct SwsContext* getContext( SDL_ffmpegConversionContext **context, int inWidth, int inHeight, enum PixelFormat inFormat, int outWidth, int outHeight, enum PixelFormat outFormat )
++struct SwsContext* getContext( SDL_ffmpegConversionContext **context, int inWidth, int inHeight, enum AVPixelFormat inFormat, int outWidth, int outHeight, enum AVPixelFormat outFormat )
+ {
+ SDL_ffmpegConversionContext *ctx = *context;
+
+@@ -621,7 +621,7 @@ int SDL_ffmpegAddVideoFrame( SDL_ffmpegFile *file, SDL_Surface *frame )
+ {
+ case 24:
+ sws_scale( getContext( &file->videoStream->conversionContext,
+- frame->w, frame->h, PIX_FMT_RGB24,
++ frame->w, frame->h, AV_PIX_FMT_RGB24,
+ file->videoStream->_ffmpeg->codec->width,
+ file->videoStream->_ffmpeg->codec->height,
+ file->videoStream->_ffmpeg->codec->pix_fmt ),
+@@ -634,7 +634,7 @@ int SDL_ffmpegAddVideoFrame( SDL_ffmpegFile *file, SDL_Surface *frame )
+ break;
+ case 32:
+ sws_scale( getContext( &file->videoStream->conversionContext,
+- frame->w, frame->h, PIX_FMT_BGR32,
++ frame->w, frame->h, AV_PIX_FMT_BGR32,
+ file->videoStream->_ffmpeg->codec->width,
+ file->videoStream->_ffmpeg->codec->height,
+ file->videoStream->_ffmpeg->codec->pix_fmt ),
+@@ -1605,7 +1605,7 @@ SDL_ffmpegStream* SDL_ffmpegAddVideoStream( SDL_ffmpegFile *file, SDL_ffmpegCode
+ stream->codec->gop_size = 12;
+
+ /* set pixel format */
+- stream->codec->pix_fmt = PIX_FMT_YUV420P;
++ stream->codec->pix_fmt = AV_PIX_FMT_YUV420P;
+
+ /* set mpeg2 codec parameters */
+ if ( stream->codec->codec_id == AV_CODEC_ID_MPEG2VIDEO )
+@@ -2223,7 +2223,7 @@ int SDL_ffmpegDecodeVideoFrame( SDL_ffmpegFile* file, AVPacket *pack, SDL_ffmpeg
+ file->videoStream->_ffmpeg->codec->height,
+ file->videoStream->_ffmpeg->codec->pix_fmt,
+ frame->overlay->w, frame->overlay->h,
+- PIX_FMT_YUYV422 ),
++ AV_PIX_FMT_YUYV422 ),
+ ( const uint8_t* const* )file->videoStream->decodeFrame->data,
+ file->videoStream->decodeFrame->linesize,
+ 0,
+@@ -2245,7 +2245,7 @@ int SDL_ffmpegDecodeVideoFrame( SDL_ffmpegFile* file, AVPacket *pack, SDL_ffmpeg
+ file->videoStream->_ffmpeg->codec->height,
+ file->videoStream->_ffmpeg->codec->pix_fmt,
+ frame->surface->w, frame->surface->h,
+- PIX_FMT_RGB32 ),
++ AV_PIX_FMT_RGB32 ),
+ ( const uint8_t* const* )file->videoStream->decodeFrame->data,
+ file->videoStream->decodeFrame->linesize,
+ 0,
+@@ -2259,7 +2259,7 @@ int SDL_ffmpegDecodeVideoFrame( SDL_ffmpegFile* file, AVPacket *pack, SDL_ffmpeg
+ file->videoStream->_ffmpeg->codec->height,
+ file->videoStream->_ffmpeg->codec->pix_fmt,
+ frame->surface->w, frame->surface->h,
+- PIX_FMT_RGB24 ),
++ AV_PIX_FMT_RGB24 ),
+ ( const uint8_t* const* )file->videoStream->decodeFrame->data,
+ file->videoStream->decodeFrame->linesize,
+ 0,