summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD35
-rw-r--r--alephone-infinity.desktop6
-rw-r--r--alephone-infinity.sh5
5 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f82586491af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = alephone-infinity
+ pkgdesc = Marathon Infinity scenario data files for Aleph One
+ pkgver = 20140104
+ pkgrel = 1
+ url = http://marathon.sourceforge.net
+ arch = any
+ license = custom
+ depends = alephone
+ conflicts = alephone-highres
+ source = MarathonInfinity-20140104-Data.zip::http://marathon.sourceforge.net/download/data.php?game=infinity
+ source = alephone-infinity.sh
+ source = LICENSE
+ source = alephone-infinity.desktop
+ sha256sums = 137329e9efdd3c219b48a56322ec5651c606c3e8078dfeaa7c9c14470cf5aa29
+ sha256sums = 593fbb16d2f72de59c7507219f84284fde65ad5f878c468f0ef604b8217b4d85
+ sha256sums = 0dde70e490e4cb3e262ed7cc4f7ef6bdc49db557a14fc8674de38b2a9a426504
+ sha256sums = 18f4458fe6b04e135947ede5ec7578858ea6c99032e434b10b05a281670c79c6
+
+pkgname = alephone-infinity
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..00639b56d078
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,13 @@
+Aleph One's GNU Public License doesn't apply to this scenario.
+All media used on this project is property of Bungie Studios
+and any modification and/or commercial distribution of it is
+strictly prohibited without the proper permission of Bungie Studios.
+You may use Bungie's copyrighted media for your private use only.
+Under no circumstances any member of the M1A1 project will be
+responsible for the misuse of the aforementioned media as they
+don't held any ownership over it. Any permission, written or verbally,
+granted by any members of the M1A1 project for modification and/or
+commercial distribution of any part of this scenario is illegal.
+
+Copyright 1997 in whole or in part Bungie Software Products Corporation.
+Created with Bungie's Forge and/or Anvil by the M1A1 team, m1a1@bungie.org
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c0a042cb2cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Contributor: prettyvanilla <prettyvanilla@lavabit.com>
+# Contributor: rabyte <rabyte__gmail>
+# Contributor: Marcin Skory <armitage at q84fh dot net>
+
+pkgname=alephone-infinity
+pkgver=20140104
+pkgrel=1
+pkgdesc="Marathon Infinity scenario data files for Aleph One"
+arch=('any')
+url="http://marathon.sourceforge.net"
+license=('custom')
+depends=('alephone')
+conflicts=('alephone-highres')
+source=(MarathonInfinity-$pkgver-Data.zip::"http://marathon.sourceforge.net/download/data.php?game=infinity"
+ "$pkgname.sh"
+ "LICENSE" # TODO: clarify where this file comes from
+ "$pkgname.desktop")
+sha256sums=('137329e9efdd3c219b48a56322ec5651c606c3e8078dfeaa7c9c14470cf5aa29'
+ '593fbb16d2f72de59c7507219f84284fde65ad5f878c468f0ef604b8217b4d85'
+ '0dde70e490e4cb3e262ed7cc4f7ef6bdc49db557a14fc8674de38b2a9a426504'
+ '18f4458fe6b04e135947ede5ec7578858ea6c99032e434b10b05a281670c79c6')
+
+package() {
+ # scenario data
+ install -d "$pkgdir"/usr/share/alephone/scenarios
+ cp -r "Marathon Infinity" "$pkgdir"/usr/share/alephone/scenarios/infinity
+ # sane permissions
+ find "$pkgdir"/usr/share/alephone/scenarios/infinity -type f -exec chmod 644 {} \;
+
+ # launcher script, license and .desktop file
+ install -Dm755 $pkgname.sh "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+}
diff --git a/alephone-infinity.desktop b/alephone-infinity.desktop
new file mode 100644
index 000000000000..524f025dd94e
--- /dev/null
+++ b/alephone-infinity.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Type=Application
+Exec=alephone-infinity
+Name=Marathon Infinity (Aleph One)
+Categories=Game;ActionGame;
+Comment=A FPS game by Bungie
diff --git a/alephone-infinity.sh b/alephone-infinity.sh
new file mode 100644
index 000000000000..577915d20d67
--- /dev/null
+++ b/alephone-infinity.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+export ALEPHONE_DATA=/usr/share/alephone:/usr/share/alephone/scenarios/infinity
+
+exec /usr/bin/alephone "$@"