summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--alephone-rubiconx.desktop7
-rw-r--r--alephone-rubiconx.sh5
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e61eb2de673
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = alephone-rubiconx
+ pkgdesc = The unofficial fourth chapter in the Marathon series.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.marathonrubicon.com/
+ arch = any
+ license = unknown
+ depends = alephone
+ source = http://files5.bungie.org/marathon/marathonRubiconX.zip
+ source = alephone-rubiconx.sh
+ source = alephone-rubiconx.desktop
+ sha256sums = f546628b654b0e5022d2a24aabc2e23043d90ec71fa4b9e7bee65cc5138aba24
+ sha256sums = 6c946c9262d7c9b0a18d9622686bc4c5e417534c0dd4728dc3fb693310cd833a
+ sha256sums = 6d9dca34cc18a095611565b13c360ebf06ae80cbbafd4b87d7e205ac6d60ca80
+
+pkgname = alephone-rubiconx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..726fada54e16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Hildigerr Vergaray <Maintainer@YmirSystems.com>
+
+pkgname=alephone-rubiconx
+pkgver=1.0
+pkgrel=1
+pkgdesc="The unofficial fourth chapter in the Marathon series."
+arch=('any')
+url="http://www.marathonrubicon.com/"
+license=('unknown')
+depends=('alephone')
+source=("http://files5.bungie.org/marathon/marathonRubiconX.zip"
+ "$pkgname.sh"
+ "$pkgname.desktop")
+sha256sums=('f546628b654b0e5022d2a24aabc2e23043d90ec71fa4b9e7bee65cc5138aba24'
+ '6c946c9262d7c9b0a18d9622686bc4c5e417534c0dd4728dc3fb693310cd833a'
+ '6d9dca34cc18a095611565b13c360ebf06ae80cbbafd4b87d7e205ac6d60ca80')
+
+prepare() {
+ find "Rubicon X ƒ" -type f -name ".DS_Store" -delete
+}
+
+package() {
+ install -Dm755 $pkgname.sh "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -d "$pkgdir"/usr/share/AlephOne/scenarios
+ cp -r "Rubicon X ƒ" "$pkgdir"/usr/share/AlephOne/scenarios/rubiconx
+ find "$pkgdir"/usr/share/AlephOne/scenarios/rubiconx -type f -exec chmod 644 {} \;
+}
diff --git a/alephone-rubiconx.desktop b/alephone-rubiconx.desktop
new file mode 100644
index 000000000000..da294d5f83fc
--- /dev/null
+++ b/alephone-rubiconx.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Exec=alephone-rubiconx
+Icon=alephone
+Name=Marthon Rubicon X (Aleph One)
+Categories=Game;ActionGame;
+Comment=An FPS game
diff --git a/alephone-rubiconx.sh b/alephone-rubiconx.sh
new file mode 100644
index 000000000000..13c7ac587b2b
--- /dev/null
+++ b/alephone-rubiconx.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+export ALEPHONE_DATA=/usr/share/AlephOne:/usr/share/AlephOne/scenarios/rubiconx
+
+exec /usr/bin/alephone "$@"