summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..411089e6c45c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = alloy-git
+ pkgdesc = A fast and minimalistic image viewer forked from the now discontinued emulsion.
+ pkgver = 1.0.0.606.g7a954e8
+ pkgrel = 1
+ url = https://github.com/ardaku/alloy
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ license = MIT
+ makedepends = cargo
+ depends = gcc-libs
+ depends = libxi
+ provides = alloy
+ conflicts = alloy
+ source = alloy-git::git+https://github.com/ardaku/alloy.git
+ sha256sums = SKIP
+
+pkgname = alloy-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..764b3924506f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=alloy-git
+pkgver=1.0.0.606.g7a954e8
+pkgrel=1
+pkgdesc="A fast and minimalistic image viewer forked from the now discontinued emulsion."
+arch=('x86_64' 'i686' 'aarch64')
+url="https://github.com/ardaku/alloy"
+license=('MIT')
+depends=('gcc-libs' 'libxi')
+makedepends=('cargo')
+optdepends=()
+provides=('alloy')
+conflicts=('alloy')
+source=($pkgname::git+https://github.com/ardaku/alloy.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname/alloy
+ echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git describe --always)
+}
+
+build() {
+ cd $pkgname
+ rm rust-toolchain.toml
+ env CARGO_INCREMENTAL=0 cargo build --release --features avif
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "$srcdir/$pkgname/target/release/alloy" "$pkgdir/usr/bin/alloy"
+}