summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD38
4 files changed, 32 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80ed568aebd0..c8b374ca76e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = allure-commandline
- pkgdesc = A flexible lightweight multi-language test report tool with the possibility to add steps, attachments, parameters and so on.
- pkgver = 1.5.0
+ pkgdesc = A flexible, lightweight multi-language test reporting tool
+ pkgver = 2.29.0
pkgrel = 1
- url = http://allure.qatools.ru
+ url = https://github.com/allure-framework/allure2
arch = i686
arch = x86_64
- depends = java-runtime
- source = https://github.com/allure-framework/allure1/releases/download/allure-core-1.5.0/allure-commandline.tar.gz
+ license = Apache-2.0
+ depends = jdk17-openjdk
+ source = https://github.com/allure-framework/allure2/releases/download/2.29.0/allure-2.29.0.tgz
source = allure
- md5sums = 2182aea7a19ee8966665904fb7572eba
- md5sums = d5cda88380d1d44d68e3eb72df369cd9
+ sha512sums = 853f31459b2d5b3ee6faf68d4cfc15dba520bcf05c5cea5e8a8e33ceb6ee7d7b3ae9badc716bc41f114a7da742841c96e8ebcb1eb4466ef9fb046a002c3a6d85
+ sha512sums = d1c50028f8ba9d791d113314cec71c5174a69e1e9136c1d22bfb58e844d20f7c15c1917184e827bbdfbd25ffd7a0fc5259004e57da331f54948f25e310927ad5
pkgname = allure-commandline
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..6cac9ed9df9f
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[allure-commandline]
+source = "github"
+github = "allure-framework/allure2"
+use_latest_release = "true"
diff --git a/PKGBUILD b/PKGBUILD
index f795124c1be4..2ef59187ab09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
-# Maintainer: Pavel Merzlyakov <pavel.merzlyakov@gmail.com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: Pavel Merzlyakov <pavel.merzlyakov@gmail.com>
-
-pkgname=allure-commandline
-_pkgname=allure
-pkgver=2.7.0
+_base=allure
+pkgname=${_base}-commandline
+pkgver=2.29.0
pkgrel=1
-pkgdesc='A flexible lightweight multi-language test report tool with the possibility to add steps, attachments, parameters and so on.'
-arch=('i686' 'x86_64')
-url='http://allure.qatools.ru'
-depends=('jdk8-openjdk')
-source=("https://github.com/allure-framework/allure2/releases/download/${pkgver}/${_pkgname}-${pkgver}.tgz" "allure")
-md5sums=('14e582816aa4c5148439dc6bc3dbe6b2' 'd5cda88380d1d44d68e3eb72df369cd9')
+pkgdesc="A flexible, lightweight multi-language test reporting tool"
+arch=(i686 x86_64)
+license=(Apache-2.0)
+url="https://github.com/${_base}-framework/${_base}2"
+depends=(jdk17-openjdk)
+source=(${url}/releases/download/${pkgver}/${_base}-${pkgver}.tgz
+ ${_base})
+sha512sums=('853f31459b2d5b3ee6faf68d4cfc15dba520bcf05c5cea5e8a8e33ceb6ee7d7b3ae9badc716bc41f114a7da742841c96e8ebcb1eb4466ef9fb046a002c3a6d85'
+ 'd1c50028f8ba9d791d113314cec71c5174a69e1e9136c1d22bfb58e844d20f7c15c1917184e827bbdfbd25ffd7a0fc5259004e57da331f54948f25e310927ad5')
package() {
- cd "${srcdir}"
- install -Dm755 allure "${pkgdir}/usr/bin/allure"
- installdir="${pkgdir}/opt/${pkgname}"
- mkdir -p "${installdir}"
- for dir in bin config lib plugins
- do
- cp -r "./${_pkgname}-${pkgver}/${dir}" "${installdir}/"
- done
+ install -Dm755 ${_base} "${pkgdir}/usr/bin/${_base}"
+ installdir="${pkgdir}/opt/${pkgname}"
+ mkdir -p "${installdir}"
+ for dir in bin config lib plugins; do
+ cp -r "./${_base}-${pkgver}/${dir}" "${installdir}/"
+ done
}