summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rwxr-xr-xallure3
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..80ed568aebd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = allure-commandline
+ pkgdesc = A flexible lightweight multi-language test report tool with the possibility to add steps, attachments, parameters and so on.
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://allure.qatools.ru
+ arch = i686
+ arch = x86_64
+ depends = java-runtime
+ source = https://github.com/allure-framework/allure1/releases/download/allure-core-1.5.0/allure-commandline.tar.gz
+ source = allure
+ md5sums = 2182aea7a19ee8966665904fb7572eba
+ md5sums = d5cda88380d1d44d68e3eb72df369cd9
+
+pkgname = allure-commandline
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01d271303c09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Pavel Merzlyakov <pavel.merzlyakov@gmail.com>
+# Contributor: Pavel Merzlyakov <pavel.merzlyakov@gmail.com>
+
+pkgname=allure-commandline
+_pkgname=allure-core
+pkgver=1.5.0
+pkgrel=1
+pkgdesc='A flexible lightweight multi-language test report tool with the possibility to add steps, attachments, parameters and so on.'
+arch=('i686' 'x86_64')
+url='http://allure.qatools.ru'
+depends=('java-runtime')
+source=("https://github.com/allure-framework/allure1/releases/download/${_pkgname}-${pkgver}/${pkgname}.tar.gz" "allure")
+md5sums=('2182aea7a19ee8966665904fb7572eba' 'd5cda88380d1d44d68e3eb72df369cd9')
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 allure "${pkgdir}/usr/bin/allure"
+ installdir="${pkgdir}/opt/${pkgname}"
+ mkdir -p "${installdir}"
+ for dir in app bin conf lib plugins
+ do
+ cp -r "./${dir}" "${installdir}/"
+ done
+}
diff --git a/allure b/allure
new file mode 100755
index 000000000000..9813e507daa7
--- /dev/null
+++ b/allure
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+ALLURE_HOME=/opt/allure-commandline/ /opt/allure-commandline/bin/allure $@