summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 110adcf8e97f..656d97c9d6a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,8 @@ pkgbase = alphaplot
depends = qt5-datavis3d
depends = qt5-script
depends = qt5-svg
+ conflicts = alphaplot-bin
+ conflicts = alphaplot-git
source = alphaplot-1.02.tar.gz::https://github.com/narunlifescience/AlphaPlot/archive/refs/tags/1.02.tar.gz
sha256sums = 90952b2036b9d25b31c0c8fb34c47ff700bb2847234dda42d900070fc60d3c61
diff --git a/PKGBUILD b/PKGBUILD
index 690e3d5a3b6f..5d5c926c49d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,6 +30,11 @@ _main_package() {
'qt5-tools'
)
+ conflicts=(
+ alphaplot-bin
+ alphaplot-git
+ )
+
if [ x"$pkgname" == x"$_pkgname" ] ; then
_main_stable
else
@@ -54,8 +59,8 @@ _main_stable() {
_main_git() {
makedepends+=('git')
- provides=("$_pkgname=${pkgver%%.r*}")
- conflicts=("$_pkgname")
+ provides+=("$_pkgname=${pkgver%%.r*}")
+ conflicts+=("$_pkgname")
_pkgsrc="$_pkgname"
source=("$_pkgsrc"::"git+$url.git")