summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d48d8826e057..d2cf8735d281 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = alphaplot
pkgdesc = Application for Scientific Data Analysis and Visualization, fork of SciDavis / QtiPlot
- pkgver = 0.01_alpha_prerelease_git
+ pkgver = 0.01_alpha_git
pkgrel = 1
url = http://alphaplot.sourceforge.net/
install = alphaplot.install
@@ -13,10 +13,9 @@ pkgbase = alphaplot
depends = glu
depends = mesa
depends = shared-mime-info
- depends = qt4
- depends = qwt5
+ depends = qt5
depends = qwtplot3d
- source = git+https://github.com/narunlifescience/alphaplot.git#branch=release-0.01A-alpha
+ source = git+https://github.com/narunlifescience/alphaplot.git
sha256sums = SKIP
pkgname = alphaplot
diff --git a/PKGBUILD b/PKGBUILD
index f957d9810723..f29706647c31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Arun Narayanankutty <n.arun.lifescience@gmail.com>
pkgname=alphaplot
-pkgver=0.01_alpha_prerelease_git
+pkgver=0.01_alpha_git
pkgrel=1
pkgdesc="Application for Scientific Data Analysis and Visualization, fork of SciDavis / QtiPlot"
url='http://alphaplot.sourceforge.net/'
@@ -10,10 +10,10 @@ license=('GPL2')
# make dependancies
makedepends=('boost' 'cmake')
-depends=('gsl' 'glu' 'mesa' 'shared-mime-info' 'qt4' 'qwt5' 'qwtplot3d')
+depends=('gsl' 'glu' 'mesa' 'shared-mime-info' 'qt5' 'qwtplot3d')
# source download from git repo & prepare
-source=(git+https://github.com/narunlifescience/alphaplot.git#branch=release-0.01A-alpha)
+source=(git+https://github.com/narunlifescience/alphaplot.git)
install=${pkgname}.install
sha256sums=('SKIP')
prepare() {
@@ -23,7 +23,7 @@ prepare() {
# start building
build() {
cd "${srcdir}/${pkgname}"
- qmake-qt4
+ qmake
make
}