summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD40
2 files changed, 23 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 421c18dd7e36..86491fada671 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sat Dec 9 11:20:47 UTC 2017
pkgbase = alpine
pkgdesc = Apache licensed PINE mail user agent
pkgver = 2.21
- pkgrel = 99
+ pkgrel = 1
url = http://repo.or.cz/alpine.git
arch = i686
arch = x86_64
@@ -19,8 +17,8 @@ pkgbase = alpine
conflicts = re-alpine
replaces = pine
options = !makeflags
- source = http://repo.or.cz/alpine.git/snapshot/04737118aa1d9ad3db63fb1064267187ae871856.tar.gz
- md5sums = b72fc6dabf93c614cab333265581362e
+ source = https://repo.or.cz/alpine.git/snapshot/08fcd1b86979b422eb586e56459d6fe15333e500.tar.gz
+ md5sums = 8a47d3bb58a7528a2e457055e66914f8
pkgname = alpine
diff --git a/PKGBUILD b/PKGBUILD
index fa9445718bb1..9041e580289f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,43 @@
-# -*- shell-script -*-
-#
-# Contributor: Adrian C. <anrxc..sysphere.org>
+# Maintainer: Aniket-Pradhan aniket17133@iiitd.ac.in
pkgname=alpine
pkgver=2.21
-pkgrel=99
-pkggit=0473711
+pkgrel=1
+pkggit=08fcd1b
arch=("i686" "x86_64")
pkgdesc="Apache licensed PINE mail user agent"
url="http://repo.or.cz/alpine.git"
license=("APACHE")
depends=("libldap" "krb5" "gettext")
optdepends=("aspell: for spell-checking support"
- "hunspell: for spell-checking support"
- "topal: glue program that links GnuPG and alpine")
+ "hunspell: for spell-checking support"
+ "topal: glue program that links GnuPG and alpine")
provides=("pine")
conflicts=("pine" "re-alpine")
replaces=("pine")
options=("!makeflags")
-source=(http://repo.or.cz/alpine.git/snapshot/04737118aa1d9ad3db63fb1064267187ae871856.tar.gz)
-md5sums=("b72fc6dabf93c614cab333265581362e")
+source=(https://repo.or.cz/alpine.git/snapshot/08fcd1b86979b422eb586e56459d6fe15333e500.tar.gz)
build() {
- cd "${srcdir}/${pkgname}-${pkggit}"
+ cd "${srcdir}/${pkgname}-${pkggit}"
-# Configure Alpine
- LIBS+="-lpam -lkrb5 -lcrypto" ./configure --prefix=/usr \
- --without-passfile --without-tcl --disable-shared \
- --with-system-pinerc=/etc/${pkgname}.d/pine.conf \
- --with-system-fixed-pinerc=/etc/${pkgname}.d/pine.conf.fixed
+ # Configure Alpine
+ LIBS+="-lpam -lkrb5 -lcrypto" ./configure --prefix=/usr \
+ --without-passfile --without-tcl --disable-shared \
+ --with-system-pinerc=/etc/${pkgname}.d/pine.conf \
+ --with-system-fixed-pinerc=/etc/${pkgname}.d/pine.conf.fixed
-# Build Alpine
- make
+ # Build Alpine
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkggit}"
+ cd "${srcdir}/${pkgname}-${pkggit}"
-# Install Alpine
- make DESTDIR="${pkgdir}" install
+ # Install Alpine
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+
+md5sums=('8a47d3bb58a7528a2e457055e66914f8')