summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD99
-rw-r--r--alps-system.service16
-rw-r--r--alps-themes-path.patch11
-rw-r--r--alps-user.service13
-rw-r--r--alps.conf19
7 files changed, 139 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02001d45f9f4..1b84a6a06b0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,27 @@
pkgbase = alps
- pkgdesc = Provides physics simulation code for strongly correlated quantum mechanical systems
- pkgver = 2.3.0
+ pkgdesc = A simple and extensible webmail
+ pkgver = 2021.09.29
pkgrel = 1
- url = http://alps.comp-phys.org
+ url = https://git.sr.ht/~migadu/alps
arch = i686
arch = x86_64
- license = custom:ALPS
- makedepends = cmake
- makedepends = gcc-fortran
- depends = boost
- depends = fftw
- depends = python2-scipy
- depends = python2-h5py
- depends = python2-matplotlib
- source = http://alps.comp-phys.org/static/software/releases/alps-2.3.0-src.tar.gz
- sha512sums = 3746621ce1a2df03b1d1c2a763e5842a6b4aa82188f6e9847728942db55f8b869d1381cfc1f1394c5f4b97ed14f16f9de2ce912b039b384b4eb1827ba65d2317
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = go
+ depends = glibc
+ options = !lto
+ backup = etc/alps.conf
+ source = alps-2021.09.29.tar.gz::https://git.sr.ht/~migadu/alps/archive/d4c35f3c3157bece8e50fd95f2ee1081be30d7ae.tar.gz
+ source = alps.conf
+ source = alps-system.service
+ source = alps-user.service
+ source = alps-themes-path.patch
+ b2sums = cd00d69b880d3daef5e28fb92144fab1e59d058b8a476353a3575d742f29d68aa2a8e0d69e1d67d99d6c3bccae9080cd1884df851320d1ec125e2bf69ae30009
+ b2sums = 8c9109649da6b030cd1c7ff32a5db1034391a8858593b649e953bd074b7329181c52575403d22b59113760423d15e0fb3cb3e8cdf5feb8415efe5aba936ae0c5
+ b2sums = 56f6f6439e537901c953a840ff08c70c9acf63b029e3298e612fb75c152d198f4d1535327b911790c01ca74b5ef5bba2a98c2fb4f14180727a457ea5b846a74e
+ b2sums = a9ef4a29b26f950f3a1bd9f262a3c23bb731b79d15ff0cee979692b0b99cb0b678ed54da7fe36449ca146aa7e1da7ba7302fb7afc4620ef1a07a119ba789464c
+ b2sums = f34d00a82db978ade7c92ca13109e73be25fdff5046e2e9f279c09733a7ce7a5e11b368ddd76234d154b9af0fd917901fda2c2b33d3f41342b3a5f6d8e6afb21
pkgname = alps
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..320d7012ffc1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+!alps.conf
+!alps-system.service
+!alps-themes-path.patch
+!alps-user.service
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 7c25911947c5..4ba879f5465e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,60 @@
-# Maintainer: Kevin Slagle <kjslag at gmail dot com>
-
-# uncomment if you want 350MB of debug symbols
-#debug=true
+# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
+_commit='d4c35f3c3157bece8e50fd95f2ee1081be30d7ae'
pkgname=alps
-_pkgver=2.3.0
-pkgver=2.3.0
+pkgver=2021.09.29
pkgrel=1
-pkgdesc="Provides physics simulation code for strongly correlated quantum mechanical systems"
-arch=('i686' 'x86_64')
-url="http://alps.comp-phys.org"
-license=('custom:ALPS')
-depends=('boost' 'fftw' 'python2-scipy' 'python2-h5py' 'python2-matplotlib')
-makedepends=('cmake' 'gcc-fortran')
-source=(http://alps.comp-phys.org/static/software/releases/alps-${_pkgver}-src.tar.gz)
-sha512sums=('3746621ce1a2df03b1d1c2a763e5842a6b4aa82188f6e9847728942db55f8b869d1381cfc1f1394c5f4b97ed14f16f9de2ce912b039b384b4eb1827ba65d2317')
-[ "$debug" = "true" ] && options=(!strip)
+pkgdesc='A simple and extensible webmail'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url='https://git.sr.ht/~migadu/alps'
+license=('MIT')
+depends=('glibc')
+makedepends=('go')
+options=('!lto')
+backup=("etc/${pkgname}.conf")
+source=("${pkgname}-${pkgver}.tar.gz::https://git.sr.ht/~migadu/${pkgname}/archive/${_commit}.tar.gz"
+ "${pkgname}.conf"
+ "${pkgname}-system.service"
+ "${pkgname}-user.service"
+ "${pkgname}-themes-path.patch")
+b2sums=('cd00d69b880d3daef5e28fb92144fab1e59d058b8a476353a3575d742f29d68aa2a8e0d69e1d67d99d6c3bccae9080cd1884df851320d1ec125e2bf69ae30009'
+ '8c9109649da6b030cd1c7ff32a5db1034391a8858593b649e953bd074b7329181c52575403d22b59113760423d15e0fb3cb3e8cdf5feb8415efe5aba936ae0c5'
+ '56f6f6439e537901c953a840ff08c70c9acf63b029e3298e612fb75c152d198f4d1535327b911790c01ca74b5ef5bba2a98c2fb4f14180727a457ea5b846a74e'
+ 'a9ef4a29b26f950f3a1bd9f262a3c23bb731b79d15ff0cee979692b0b99cb0b678ed54da7fe36449ca146aa7e1da7ba7302fb7afc4620ef1a07a119ba789464c'
+ 'f34d00a82db978ade7c92ca13109e73be25fdff5046e2e9f279c09733a7ce7a5e11b368ddd76234d154b9af0fd917901fda2c2b33d3f41342b3a5f6d8e6afb21')
+
+prepare(){
+ patch -d "${pkgname}-${_commit}" -p1 <"${pkgname}-themes-path".patch
+}
build() {
- # http://alps.comp-phys.org/mediawiki/index.php/Download_and_install_ALPS_2#Build_ALPS
-
- cd "${srcdir}/alps-${_pkgver}-src/alps"
-
- # this line is recommended, but gave a compilation error
- # [ "$CARCH" = "x86_64" ] && _CMAKE_ARGS=-DLAPACK_64_BIT=ON
-
- if [ "$debug" = "true" ]
- then CFLAGS="-g $CFLAGS"
- CXXFLAGS="-g $CXXFLAGS"
- fi
-
- mkdir -p build
- cd build
-
- cmake ../ -DCMAKE_INSTALL_PREFIX=/usr -DPYTHON_INTERPRETER=/usr/bin/python2 $_CMAKE_ARGS
- make
- make test || true
-
- # 2.2.b3-r7462:
- # 99% tests passed, 1 tests failed out of 149
- # The following tests FAILED:
- # 112 - expression (Failed)
+ cd "${pkgname}-${_commit}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -o ${pkgname} ./cmd/alps
}
package() {
- cd "${srcdir}/alps-${_pkgver}-src/alps/build"
- make DESTDIR="${pkgdir}" install
- install -Dm644 ../LICENSE.txt "${pkgdir}/usr/share/licenses/alps/LICENSE"
-
- cd "${pkgdir}"
- mv usr/tutorials usr/share/alps/
-
- # make python see alps (the alternative is to run with alpspython)
- mkdir -p usr/lib/python2.7/site-packages/
- ln -s ../../pyalps usr/lib/python2.7/site-packages/
+ # config
+ install -D -m644 ${pkgname}.conf "${pkgdir}/etc/${pkgname}.conf"
+ # services
+ install -D -m644 ${pkgname}-system.service \
+ "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ install -D -m644 ${pkgname}-user.service \
+ "${pkgdir}/usr/lib/systemd/user/${pkgname}.service"
+
+ cd "${pkgname}-${_commit}"
+ # binary
+ install -D -m755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ # themes
+ install -d -m755 "${pkgdir}/usr/lib/${pkgname}"
+ cp -a themes "${pkgdir}/usr/lib/${pkgname}"
+ # docs
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ cp -a docs "${pkgdir}/usr/share/doc/${pkgname}"
+ # license
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/alps-system.service b/alps-system.service
new file mode 100644
index 000000000000..3febcaaccc0a
--- /dev/null
+++ b/alps-system.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=A simple and extensible webmail
+Documentation=https://git.sr.ht/~migadu/alps/tree/master/item/docs
+After=network.target
+Wants=network-online.target
+
+[Service]
+DynamicUser=yes
+User=alps
+Group=alps
+EnvironmentFile=/etc/alps.conf
+ExecStart=/usr/bin/alps $ALPS_OPTIONS $ALPS_SERVERS
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target
diff --git a/alps-themes-path.patch b/alps-themes-path.patch
new file mode 100644
index 000000000000..bc8b338f805f
--- /dev/null
+++ b/alps-themes-path.patch
@@ -0,0 +1,11 @@
+--- a/cmd/alps/main.go 2022-02-15 11:40:22.453874404 +0100
++++ b/cmd/alps/main.go 2022-02-15 11:41:53.880538359 +0100
+@@ -23,7 +23,7 @@
+ _ "git.sr.ht/~migadu/alps/plugins/viewtext"
+ )
+
+-var themesPath = "./themes"
++var themesPath = "/usr/lib/alps/themes"
+
+ func main() {
+ var (
diff --git a/alps-user.service b/alps-user.service
new file mode 100644
index 000000000000..a9041128567e
--- /dev/null
+++ b/alps-user.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=A simple and extensible webmail
+Documentation=https://git.sr.ht/~migadu/alps/tree/master/item/docs
+After=network.target
+Wants=network-online.target
+
+[Service]
+EnvironmentFile=%E/alps/alps.conf
+ExecStart=/usr/bin/alps $ALPS_OPTIONS $ALPS_SERVERS
+Restart=on-failure
+
+[Install]
+WantedBy=default.target
diff --git a/alps.conf b/alps.conf
new file mode 100644
index 000000000000..9574f9a4ddbb
--- /dev/null
+++ b/alps.conf
@@ -0,0 +1,19 @@
+# Global alps configuration file readed by systemd system alps.service
+#
+# Copy it as ${XDG_CONFIG_HOME}/alps/alps.conf for start service as systemd
+# user unit
+
+# Application options
+# Note: Theme is mandatory (see /usr/lib/alps/themes for more themes)
+ALPS_OPTIONS="-theme alps -addr localhost:1323"
+
+# Servers
+ALPS_SERVERS="imaps://imap.migadu.com smtps://smtp.migadu.com"
+
+# More examples (see cli.md in docs for more info)
+#
+# More options (enable debug and provide a login-key)
+#ALPS_OPTIONS="-theme alps -addr localhost:1323 -debug -login-key secret"
+#
+# Adding optional CardDAV and CalDAV to servers
+#ALPS_SERVERS="imaps://imap.migadu.com smtps://smtp.migadu.com https://cdav.migadu.com/addressbooks/MAILBOXADDRESS/family https://cdav.migadu.com/calendars/MAILBOXADDRESS/home"