summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79f195c87a84..424dbfb5991b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,12 +6,13 @@ pkgbase = alpscore
arch = i686
arch = x86_64
license = GPL2
- depends = cmake>=2.8.12
- depends = boost>=1.54.0
- depends = hdf5>=1.8
- optdepends = openmpi: for MPI support
+ depends = cmake
+ depends = boost
+ depends = hdf5
provides = alpscore=0.5.4
conflicts = alpscore-git
+ conflicts = alpscore-openmpi
+ conflicts = alpscore-openmpi-git
conflicts = alps
source = https://github.com/ALPSCore/ALPSCore/archive/v0.5.4.tar.gz
md5sums = b887c9328e2a22afa123663cf888b768
diff --git a/PKGBUILD b/PKGBUILD
index f857043272b4..09b84974c4c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,27 +6,21 @@ pkgdesc="ALPS Core libraries for numerical simulations of condensed matter syste
arch=(i686 x86_64)
url="http://alpscore.org"
license=('GPL2')
-depends=('cmake>=2.8.12' 'boost>=1.54.0' 'hdf5>=1.8')
-optdepends=('openmpi: for MPI support')
+depends=('cmake' 'boost' 'hdf5')
provides=($pkgname=$pkgver)
-conflicts=(alpscore-git alps)
+conflicts=(alpscore-git alpscore-openmpi alpscore-openmpi-git alps)
source=("https://github.com/ALPSCore/ALPSCore/archive/v$pkgver.tar.gz")
md5sums=('b887c9328e2a22afa123663cf888b768')
build() {
- cd "ALPSCore-$pkgver"
+ cd "ALPSCore-$pkgver"
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DDocumentation=OFF ..
- make
-}
-
-check() {
- cd "ALPSCore-$pkgver/build"
- make test
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DTesting=OFF -DDocumentation=OFF ..
+ make
}
package() {
- cd "ALPSCore-$pkgver/build"
- make DESTDIR="$pkgdir/" install
+ cd "ALPSCore-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
}