summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rw-r--r--alsa-patch-bay.install9
-rw-r--r--alsa-patch-bay.patch78
4 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fb4e5ec579a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = alsa-patch-bay
+ pkgdesc = A graphical patch bay for the ALSA sequencer API and the JACK audio API
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://pkl.net/~node/software/alsa-patch-bay/
+ install = alsa-patch-bay.install
+ arch = i686
+ license = GPL
+ depends = fltk
+ depends = jack
+ source = http://pkl.net/~node/software/alsa-patch-bay/alsa-patch-bay-1.0.0.tar.gz
+ source = alsa-patch-bay.patch
+ md5sums = 3aa458f6bee8b83b2cf7330707d72430
+ md5sums = f2b643febf922c93777452e6d809af00
+
+pkgname = alsa-patch-bay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f740e53f8953
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: masutu <masutu dot arch at gmail dot com>
+# Contributor: masutu <masutu dot arch at gmail dot com>
+pkgname=alsa-patch-bay
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A graphical patch bay for the ALSA sequencer API and the JACK audio API"
+arch=('i686') #x86_64 not working
+url="http://pkl.net/~node/software/alsa-patch-bay/"
+license=('GPL')
+depends=('fltk' 'jack')
+install="alsa-patch-bay.install"
+source=(http://pkl.net/~node/software/$pkgname/$pkgname-$pkgver.tar.gz $pkgname.patch)
+md5sums=('3aa458f6bee8b83b2cf7330707d72430'
+ 'f2b643febf922c93777452e6d809af00')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < ../../alsa-patch-bay.patch
+ ./configure --prefix=/usr
+ sed -i '946d' src/Makefile
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/alsa-patch-bay.install b/alsa-patch-bay.install
new file mode 100644
index 000000000000..48573eee8b52
--- /dev/null
+++ b/alsa-patch-bay.install
@@ -0,0 +1,9 @@
+post_install() {
+ ln -s /usr/bin/alsa-patch-bay /usr/bin/jack-patch-bay
+}
+post_update() {
+post_install
+}
+pre_remove() {
+ rm /usr/bin/jack-patch-bay
+}
diff --git a/alsa-patch-bay.patch b/alsa-patch-bay.patch
new file mode 100644
index 000000000000..740302c52fd2
--- /dev/null
+++ b/alsa-patch-bay.patch
@@ -0,0 +1,78 @@
+diff -ru alsa-patch-bay-1.0.0/src/driver/jack/jack-addr.cpp alsa-patch-bay-1.0.0_patched/src/driver/jack/jack-addr.cpp
+--- alsa-patch-bay-1.0.0/src/driver/jack/jack-addr.cpp 2003-02-07 22:06:25.000000000 +0100
++++ alsa-patch-bay-1.0.0_patched/src/driver/jack/jack-addr.cpp 2010-03-03 20:28:29.000000000 +0100
+@@ -10,6 +10,8 @@
+ */
+
+ #include <iostream>
++#include <string.h>
++#include <cstdlib>
+
+ #include "jack-addr.h"
+
+@@ -56,7 +58,7 @@
+ {
+ char * ptr;
+
+- ptr = strchr (_portName.c_str(), ':');
++ ptr = strchr (const_cast<char *>(_portName.c_str()), ':');
+ ptr++;
+
+ std::string ports (ptr);
+diff -ru alsa-patch-bay-1.0.0/src/driver/jack/jack-driver.cpp alsa-patch-bay-1.0.0_patched/src/driver/jack/jack-driver.cpp
+--- alsa-patch-bay-1.0.0/src/driver/jack/jack-driver.cpp 2003-02-08 11:50:34.000000000 +0100
++++ alsa-patch-bay-1.0.0_patched/src/driver/jack/jack-driver.cpp 2010-03-03 20:24:02.000000000 +0100
+@@ -12,6 +12,8 @@
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <errno.h>
++#include <string.h>
++#include <stdlib.h>
+
+ #include "jack-driver.h"
+ #include "jack-addr.h"
+diff -ru alsa-patch-bay-1.0.0/src/driver.cpp alsa-patch-bay-1.0.0_patched/src/driver.cpp
+--- alsa-patch-bay-1.0.0/src/driver.cpp 2003-01-04 09:42:44.000000000 +0100
++++ alsa-patch-bay-1.0.0_patched/src/driver.cpp 2010-03-03 21:51:51.000000000 +0100
+@@ -15,6 +15,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <fcntl.h>
++#include <cstdlib>
+
+ #include "driver.h"
+
+diff -ru alsa-patch-bay-1.0.0/src/main.cpp alsa-patch-bay-1.0.0_patched/src/main.cpp
+--- alsa-patch-bay-1.0.0/src/main.cpp 2003-10-21 14:00:31.000000000 +0200
++++ alsa-patch-bay-1.0.0_patched/src/main.cpp 2010-03-03 21:49:39.000000000 +0100
+@@ -102,7 +102,7 @@
+ else
+ driver++;
+
+- ptr = strchr (driver, '-');
++ ptr = const_cast<char *>(strchr (driver, '-'));
+ if (ptr)
+ *ptr = '\0';
+
+diff -ru alsa-patch-bay-1.0.0/src/misc.cpp alsa-patch-bay-1.0.0_patched/src/misc.cpp
+--- alsa-patch-bay-1.0.0/src/misc.cpp 2002-11-25 20:48:10.000000000 +0100
++++ alsa-patch-bay-1.0.0_patched/src/misc.cpp 2010-03-03 21:53:14.000000000 +0100
+@@ -10,6 +10,7 @@
+ */
+
+ #include <sstream>
++#include <cstdlib>
+
+ #include "misc.h"
+
+diff -ru alsa-patch-bay-1.0.0/src/plugins.cpp alsa-patch-bay-1.0.0_patched/src/plugins.cpp
+--- alsa-patch-bay-1.0.0/src/plugins.cpp 2003-01-04 09:43:15.000000000 +0100
++++ alsa-patch-bay-1.0.0_patched/src/plugins.cpp 2010-03-03 23:12:10.000000000 +0100
+@@ -14,6 +14,7 @@
+ #include <dirent.h>
+ #include <errno.h>
+ #include <string.h>
++#include <cstdlib>
+
+ #include <iostream>
+ #include <list>