summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--caps_9.x.patch22
-rw-r--r--false_error.patch13
-rw-r--r--makefile.patch13
5 files changed, 22 insertions, 80 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3985b37a631..1be6e471daf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,17 @@
pkgbase = alsaequal
pkgdesc = Real-time adjustable equalizer plugin for ALSA sound server
- pkgver = 0.6
- pkgrel = 16
- url = https://web.archive.org/web/20161105202833/http://thedigitalmachine.net/alsaequal.html
+ pkgver = v0.7.1
+ pkgrel = 1
+ url = https://github.com/bassdr/alsaequal
install = alsaequal.install
arch = i686
arch = x86_64
license = GPL2
depends = alsa-lib
depends = caps
+ depends = ladspa
optdepends = swh-plugins: to use the mbeq equalizer (15-band)
- source = https://launchpad.net/ubuntu/+archive/primary/+files/alsaequal_0.6.orig.tar.bz2
- source = makefile.patch
- source = false_error.patch
- source = caps_9.x.patch
- sha256sums = 916e7d152added24617efc350142438a46099efe062bd8781d36dbf10b4e6ff0
- sha256sums = c3bde63c45066f26fec21a38f6b4fc70d1fe534b9d20c4a9655fc15004c03792
- sha256sums = c1a02bfed6be6385e8ab4ebe7c9c3844e9c0937fbafe0f8d948842c2b7c9f7f0
- sha256sums = ba4e79459af3dab96a808ab581759a5a1cf82a1fe69d014cce959d7686e2313e
+ source = alsaequal::git+https://github.com/bassdr/alsaequal#tag=v0.7.1
+ sha256sums = SKIP
pkgname = alsaequal
-
diff --git a/PKGBUILD b/PKGBUILD
index 2432570b252d..bdcf3d84a987 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# $Id: PKGBUILD, 2009/06/6$
-# Maintainer: Jens John <asterisk@2ion.de>
-# Past maintainer: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
+# Maintainer: Ayush Shenoy <ayush.shenoy92@gmail.com>
+# Past maintainers:
+# * Jens John <asterisk@2ion.de>
+# * Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
# Contributors:
# * Alireza Savand <alireza.savand@gmail.com>
# * Maxime de Roucy <maxime.deroucy@gmail.com>
@@ -10,31 +11,25 @@
# * Bjorn Neergaard <bjorn@neersighted.com>
pkgname=alsaequal
-pkgver=0.6
-pkgrel=16
+pkgver=v0.7.1
+pkgrel=1
pkgdesc='Real-time adjustable equalizer plugin for ALSA sound server'
-url='https://web.archive.org/web/20161105202833/http://thedigitalmachine.net/alsaequal.html'
+url='https://github.com/bassdr/alsaequal'
license=('GPL2')
arch=('i686' 'x86_64')
-depends=('alsa-lib' 'caps')
+depends=('alsa-lib' 'caps' 'ladspa')
optdepends=('swh-plugins: to use the mbeq equalizer (15-band)')
install=alsaequal.install
-source=("https://launchpad.net/ubuntu/+archive/primary/+files/alsaequal_${pkgver}.orig.tar.bz2"
- 'makefile.patch'
- 'false_error.patch'
- 'caps_9.x.patch')
-sha256sums=('916e7d152added24617efc350142438a46099efe062bd8781d36dbf10b4e6ff0'
- 'c3bde63c45066f26fec21a38f6b4fc70d1fe534b9d20c4a9655fc15004c03792'
- 'c1a02bfed6be6385e8ab4ebe7c9c3844e9c0937fbafe0f8d948842c2b7c9f7f0'
- 'ba4e79459af3dab96a808ab581759a5a1cf82a1fe69d014cce959d7686e2313e')
+source=("alsaequal::git+https://github.com/bassdr/alsaequal#tag=$pkgver")
+sha256sums=('SKIP')
-prepare() {
- cd "$pkgname"
- for f in "$srcdir"/*.patch; do patch < "$f"; done
-}
+#prepare() {
+ #cd "$pkgname"
+ #for f in "$srcdir"/*.patch; do patch < "$f"; done
+#}
build() {
cd "$pkgname"
@@ -43,6 +38,7 @@ build() {
package() {
cd "$pkgname"
- install -dm755 "$pkgdir"/usr/lib/alsa-lib
+ install -dm755 "$pkgdir" /usr/lib/alsa-lib
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
make DESTDIR="$pkgdir" install
}
diff --git a/caps_9.x.patch b/caps_9.x.patch
deleted file mode 100644
index e5856b333e11..000000000000
--- a/caps_9.x.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-
---- ctl_equal.c 2009-01-31 23:06:47.000000000 +0100
-+++ ctl_equal.c 2014-01-23 15:23:01.000000000 +0100
-@@ -167,7 +167,7 @@
- snd_ctl_equal_t *equal;
- const char *controls = ".alsaequal.bin";
- const char *library = "/usr/lib/ladspa/caps.so";
-- const char *module = "Eq";
-+ const char *module = "Eq10";
- long channels = 2;
- const char *sufix = " Playback Volume";
- int err, i, index;
---- pcm_equal.c 2010-02-01 23:55:00.000000000 +0100
-+++ pcm_equal.c 2014-01-23 15:23:16.000000000 +0100
-@@ -151,7 +151,7 @@
- snd_config_t *sconf = NULL;
- const char *controls = ".alsaequal.bin";
- const char *library = "/usr/lib/ladspa/caps.so";
-- const char *module = "Eq";
-+ const char *module = "Eq10";
- long channels = 2;
- int err;
diff --git a/false_error.patch b/false_error.patch
deleted file mode 100644
index a3221138dcea..000000000000
--- a/false_error.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- ctl_eqaul.c 2013-02-06 22:09:11.000000000 +0100
-+++ ctl_equal.c 2013-02-06 22:10:02.000000000 +0100
-@@ -263,8 +263,8 @@
- for(i = 0; i < equal->num_input_controls; i++) {
- if(equal->control_data->control[i].type == LADSPA_CNTRL_INPUT) {
- index = equal->control_data->control[i].index;
-- if(equal->klass->PortDescriptors[index] !=
-- (LADSPA_PORT_INPUT | LADSPA_PORT_CONTROL)) {
-+ if(equal->klass->PortDescriptors[index] &
-+ (LADSPA_PORT_INPUT | LADSPA_PORT_CONTROL) == 0) {
- SNDERR("Problem with control file %s, %d.", controls, index);
- return -1;
- }
diff --git a/makefile.patch b/makefile.patch
deleted file mode 100644
index 20baf11bd04b..000000000000
--- a/makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile 2009-08-27 18:09:24.000000000 -0400
-+++ Makefile 2009-08-27 18:09:49.000000000 -0400
-@@ -45,8 +45,8 @@
-
- install: all
- @echo Installing...
-- $(Q)install -m 644 $(SND_PCM_BIN) ${DESTDIR}/usr/lib/alsa-lib/
-- $(Q)install -m 644 $(SND_CTL_BIN) ${DESTDIR}/usr/lib/alsa-lib/
-+ $(Q)install -m 755 $(SND_PCM_BIN) ${DESTDIR}/usr/lib/alsa-lib/
-+ $(Q)install -m 755 $(SND_CTL_BIN) ${DESTDIR}/usr/lib/alsa-lib/
-
- uninstall:
- @echo Un-installing...