summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
-rw-r--r--alsaequal.install7
-rw-r--r--caps_9.x.patch22
-rw-r--r--false_error.patch13
-rw-r--r--makefile.patch13
6 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94e88329629b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = alsaequal
+ pkgdesc = Real-time adjustable equalizer plugin for ALSA sound server
+ pkgver = 0.6
+ pkgrel = 13
+ url = http://www.thedigitalmachine.net/alsaequal.html
+ install = alsaequal.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = alsa-lib
+ depends = ladspa
+ optdepends = caps: to use the Eq CAPS equalizer (10-band)
+ optdepends = swh-plugins: to use the mbeq equalizer (15-band)
+ source = http://www.thedigitalmachine.net/tools/alsaequal-0.6.tar.bz2
+ source = makefile.patch
+ source = false_error.patch
+ source = caps_9.x.patch
+ sha256sums = 916e7d152added24617efc350142438a46099efe062bd8781d36dbf10b4e6ff0
+ sha256sums = c3bde63c45066f26fec21a38f6b4fc70d1fe534b9d20c4a9655fc15004c03792
+ sha256sums = c1a02bfed6be6385e8ab4ebe7c9c3844e9c0937fbafe0f8d948842c2b7c9f7f0
+ sha256sums = ba4e79459af3dab96a808ab581759a5a1cf82a1fe69d014cce959d7686e2313e
+
+pkgname = alsaequal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e1ff034c231
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id: PKGBUILD, 2009/06/6$
+# Maintainer: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
+# Contributors:
+# * Alireza Savand <alireza.savand@gmail.com>
+# * Maxime de Roucy <maxime.deroucy@gmail.com>
+# * Xyne <ac xunilhcra enyx, backwards>
+# * speeddefrost
+# * stefanr
+# * Bjorn Neergaard <bjorn@neersighted.com>
+
+pkgname=alsaequal
+pkgver=0.6
+pkgrel=13
+
+pkgdesc='Real-time adjustable equalizer plugin for ALSA sound server'
+url='http://www.thedigitalmachine.net/alsaequal.html'
+license=('GPL2')
+arch=('i686' 'x86_64')
+
+depends=('alsa-lib' 'ladspa')
+optdepends=('caps: to use the Eq CAPS equalizer (10-band)'
+ 'swh-plugins: to use the mbeq equalizer (15-band)')
+
+source=("http://www.thedigitalmachine.net/tools/alsaequal-$pkgver.tar.bz2"
+ 'makefile.patch'
+ 'false_error.patch'
+ 'caps_9.x.patch')
+sha256sums=('916e7d152added24617efc350142438a46099efe062bd8781d36dbf10b4e6ff0'
+ 'c3bde63c45066f26fec21a38f6b4fc70d1fe534b9d20c4a9655fc15004c03792'
+ 'c1a02bfed6be6385e8ab4ebe7c9c3844e9c0937fbafe0f8d948842c2b7c9f7f0'
+ 'ba4e79459af3dab96a808ab581759a5a1cf82a1fe69d014cce959d7686e2313e')
+install=alsaequal.install
+
+prepare() {
+ cd "$pkgname"
+ for f in "$srcdir"/*.patch; do patch < "$f"; done
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -dm755 "$pkgdir"/usr/lib/alsa-lib
+ make DESTDIR="$pkgdir" install
+}
diff --git a/alsaequal.install b/alsaequal.install
new file mode 100644
index 000000000000..cdb79eee4938
--- /dev/null
+++ b/alsaequal.install
@@ -0,0 +1,7 @@
+post_install() {
+ cat << MSG
+==> See http://www.thedigitalmachine.net/alsaequal.html and the Arch ALSA wiki
+ page for configuration instructions.
+MSG
+}
+
diff --git a/caps_9.x.patch b/caps_9.x.patch
new file mode 100644
index 000000000000..e5856b333e11
--- /dev/null
+++ b/caps_9.x.patch
@@ -0,0 +1,22 @@
+
+--- ctl_equal.c 2009-01-31 23:06:47.000000000 +0100
++++ ctl_equal.c 2014-01-23 15:23:01.000000000 +0100
+@@ -167,7 +167,7 @@
+ snd_ctl_equal_t *equal;
+ const char *controls = ".alsaequal.bin";
+ const char *library = "/usr/lib/ladspa/caps.so";
+- const char *module = "Eq";
++ const char *module = "Eq10";
+ long channels = 2;
+ const char *sufix = " Playback Volume";
+ int err, i, index;
+--- pcm_equal.c 2010-02-01 23:55:00.000000000 +0100
++++ pcm_equal.c 2014-01-23 15:23:16.000000000 +0100
+@@ -151,7 +151,7 @@
+ snd_config_t *sconf = NULL;
+ const char *controls = ".alsaequal.bin";
+ const char *library = "/usr/lib/ladspa/caps.so";
+- const char *module = "Eq";
++ const char *module = "Eq10";
+ long channels = 2;
+ int err;
diff --git a/false_error.patch b/false_error.patch
new file mode 100644
index 000000000000..a3221138dcea
--- /dev/null
+++ b/false_error.patch
@@ -0,0 +1,13 @@
+--- ctl_eqaul.c 2013-02-06 22:09:11.000000000 +0100
++++ ctl_equal.c 2013-02-06 22:10:02.000000000 +0100
+@@ -263,8 +263,8 @@
+ for(i = 0; i < equal->num_input_controls; i++) {
+ if(equal->control_data->control[i].type == LADSPA_CNTRL_INPUT) {
+ index = equal->control_data->control[i].index;
+- if(equal->klass->PortDescriptors[index] !=
+- (LADSPA_PORT_INPUT | LADSPA_PORT_CONTROL)) {
++ if(equal->klass->PortDescriptors[index] &
++ (LADSPA_PORT_INPUT | LADSPA_PORT_CONTROL) == 0) {
+ SNDERR("Problem with control file %s, %d.", controls, index);
+ return -1;
+ }
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..20baf11bd04b
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,13 @@
+--- Makefile 2009-08-27 18:09:24.000000000 -0400
++++ Makefile 2009-08-27 18:09:49.000000000 -0400
+@@ -45,8 +45,8 @@
+
+ install: all
+ @echo Installing...
+- $(Q)install -m 644 $(SND_PCM_BIN) ${DESTDIR}/usr/lib/alsa-lib/
+- $(Q)install -m 644 $(SND_CTL_BIN) ${DESTDIR}/usr/lib/alsa-lib/
++ $(Q)install -m 755 $(SND_PCM_BIN) ${DESTDIR}/usr/lib/alsa-lib/
++ $(Q)install -m 755 $(SND_CTL_BIN) ${DESTDIR}/usr/lib/alsa-lib/
+
+ uninstall:
+ @echo Un-installing...