summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9436d98ec85f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = alt-git
+ pkgdesc = Command line utility that attempts to find the "alternate path" for the provided path
+ pkgver = 103
+ pkgrel = 1
+ url = https://github.com/uptech/alt
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ source = git+https://github.com/uptech/alt.git
+ md5sums = SKIP
+
+pkgname = alt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99b4490a2061
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Wesley Moore <wes@wezm.net>
+_pkgname=alt
+pkgname=${_pkgname}-git
+pkgver=103
+pkgrel=1
+pkgdesc='Command line utility that attempts to find the "alternate path" for the provided path'
+arch=('i686' 'x86_64')
+url="https://github.com/uptech/alt"
+license=('MIT')
+depends=()
+makedepends=('rust' 'cargo' 'git')
+source=("git+https://github.com/uptech/alt.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git rev-list --count HEAD
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ cargo build --release
+ install -Dm755 "$srcdir/$_pkgname/target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ #install -Dm644 "$srcdir/$_pkgname/contrib/man/$_pkgname.1" "$pkgdir/usr/share/man/man1/$_pkgname.1"
+}