summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--altermime-0.3.10-cflags.patch11
-rw-r--r--altermime-0.3.10-fprintf-compiler-error.patch45
4 files changed, 20 insertions, 90 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8eeb5a239c02..098ab46eba2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,14 @@
-# Generated by mksrcinfo v8
-# Sat Oct 21 09:21:33 UTC 2017
pkgbase = altermime
pkgdesc = MIME encoded email pack alteration tool
- pkgver = 0.3.10
+ pkgver = 0.3.11
pkgrel = 0
- url = http://www.pldaniels.com/altermime/
+ url = https://pldaniels.com/altermime
arch = i686
arch = x86_64
arch = armv7h
arch = armv6h
- license = BSD
- depends = glibc
- source = http://www.pldaniels.com/altermime/altermime-0.3.10.tar.gz
- source = altermime-0.3.10-fprintf-compiler-error.patch
- source = altermime-0.3.10-cflags.patch
- md5sums = aaf0ad8029958a2dc6da3abb4dc178c2
- md5sums = 4b8ce1a5878e595db6fdec8bb2bc3871
- md5sums = 194efdd0f1cc15e0b8a3f7bbf8b2acd3
+ license = custom
+ source = https://pldaniels.com/altermime/altermime-0.3.11.tar.gz
+ sha512sums = 9e5082abc72a0f0d77ee947c61c654ff7f90151b7d7a7e36819e85420dbd9e7cfdb4d053cebcbfd629380aab3d9998ed802a59212ac5c433d50e006b1558dc5f
pkgname = altermime
-
diff --git a/PKGBUILD b/PKGBUILD
index 3f6ad2602982..0379b97a12ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,29 @@
-# Maintainer: Swift Geek
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Sebastian 'Swift Geek' Grzywna <swiftgeek@gmail.com>
pkgname=altermime
-pkgver=0.3.10
+pkgver=0.3.11
pkgrel=0
pkgdesc="MIME encoded email pack alteration tool"
arch=('i686' 'x86_64' 'armv7h' 'armv6h')
-url="http://www.pldaniels.com/altermime/"
-license=('BSD')
-depends=('glibc')
-source=("http://www.pldaniels.com/altermime/altermime-${pkgver}.tar.gz"
- "altermime-0.3.10-fprintf-compiler-error.patch"
- "altermime-0.3.10-cflags.patch")
-md5sums=('aaf0ad8029958a2dc6da3abb4dc178c2'
- '4b8ce1a5878e595db6fdec8bb2bc3871'
- '194efdd0f1cc15e0b8a3f7bbf8b2acd3')
+url="https://pldaniels.com/${pkgname}"
+license=('custom')
+source=("${url}/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('9e5082abc72a0f0d77ee947c61c654ff7f90151b7d7a7e36819e85420dbd9e7cfdb4d053cebcbfd629380aab3d9998ed802a59212ac5c433d50e006b1558dc5f')
prepare() {
- cd "$srcdir/${pkgname}-${pkgver}"
- patch -Np0 -i "${srcdir}/altermime-0.3.10-fprintf-compiler-error.patch"
- patch -Np0 -i "${srcdir}/altermime-0.3.10-cflags.patch"
+ sed -i 's/^CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)/CFLAGS=-Wall $(ALTERMIME_OPTIONS)/' "${pkgname}-${pkgver}/Makefile"
+ sed -i 's/^ ${CC} ${CFLAGS} altermime.c ${OBJS} -o altermime/ ${CC} ${CFLAGS} ${LDFLAGS} altermime.c ${OBJS} -o altermime/' "${pkgname}-${pkgver}/Makefile"
}
build() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "$srcdir/${pkgname}-${pkgver}"
- install -d "$pkgdir/usr/bin/"
- install -m 755 altermime "$pkgdir/usr/bin/"
- install -d "$pkgdir/usr/share/licenses/altermime"
- install -m 644 LICENCE "$pkgdir/usr/share/licenses/altermime"
-
+ cd "${pkgname}-${pkgver}"
+ install -d "${pkgdir}/usr/bin/"
+ install -m 755 ${pkgname} "${pkgdir}/usr/bin/"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}"
}
diff --git a/altermime-0.3.10-cflags.patch b/altermime-0.3.10-cflags.patch
deleted file mode 100644
index c18518ff4af4..000000000000
--- a/altermime-0.3.10-cflags.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2008-11-16 08:45:45.000000000 +0000
-+++ Makefile 2011-02-11 16:33:17.777602478 +0000
-@@ -9,7 +9,7 @@
- # opposite of a disclaimer.
- #ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT
- ALTERMIME_OPTIONS=
--CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
-+#CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
- OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
-
-
diff --git a/altermime-0.3.10-fprintf-compiler-error.patch b/altermime-0.3.10-fprintf-compiler-error.patch
deleted file mode 100644
index ba19ebf40c06..000000000000
--- a/altermime-0.3.10-fprintf-compiler-error.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- qpe.c.orig 2008-11-16 08:45:45.000000000 +0000
-+++ qpe.c 2008-11-23 12:06:08.000000000 +0000
-@@ -97,7 +97,7 @@
- op+= strlen(paragraph);// +3; /** jump the output + =\r\n **/
- out_remaining-= (strlen(paragraph)); // Was +3, updated to fix Outlook problems
-
-- QPD fprintf(stdout, "Soft break (%d + %d > 76 char) for '%s'\n", current_line_length, charout_size, paragraph);
-+ QPD fprintf(stdout, "Soft break (%Zd + %d > 76 char) for '%s'\n", current_line_length, charout_size, paragraph);
-
- /** reinitialize the paragraph **/
- paragraph[0] = '\0';
-@@ -108,7 +108,7 @@
- }
-
- snprintf(pp, pp_remaining, "%s", charout);
-- QPD fprintf(stdout,"charout='%s', size=%d, pp_remain=%d result='%s'\n", charout, charout_size, pp_remaining, paragraph);
-+ QPD fprintf(stdout,"charout='%s', size=%d, pp_remain=%Zd result='%s'\n", charout, charout_size, pp_remaining, paragraph);
- pp += charout_size;
- pp_remaining -= charout_size;
- p++;
-@@ -149,13 +149,13 @@
- out_size = in_size *3;
- in_buffer = malloc( sizeof(char) *in_size +1);
- if (in_buffer == NULL) {
-- QPD fprintf(stdout,"Error allocating %d bytes for input buffer\n", in_size);
-+ QPD fprintf(stdout,"Error allocating %Zd bytes for input buffer\n", in_size);
- return -1;
- }
-
- out_buffer = malloc( sizeof(char) *out_size *3 +1);
- if (in_buffer == NULL) {
-- QPD fprintf(stdout,"Error allocating %d bytes for output buffer\n", out_size);
-+ QPD fprintf(stdout,"Error allocating %Zd bytes for output buffer\n", out_size);
- return -1;
- }
-
-@@ -169,7 +169,7 @@
- ** we segfault ;) **/
- *(in_buffer +in_size) = '\0';
-
-- QPD fprintf(stdout,"file %s is loaded, size = %d\n", fname, in_size);
-+ QPD fprintf(stdout,"file %s is loaded, size = %Zd\n", fname, in_size);
-
- qp_encode( out_buffer, out_size, in_buffer, in_size );
-